Project

General

Profile

Bug #10070

Error when putting uuid.hive in inventory-updates

Added by Alexis MOUSSET over 2 years ago. Updated over 2 years ago.

Status:
Released
Priority:
N/A
Category:
-
Target version:
Severity:
User visibility:
Effort required:
Priority:

Description

[Wed Jan 25 11:00:38 2017] [error] [client ::1] Unable to PUT new contents for /inventory-updates/uuid.hive.  [403, #0]
[Wed Jan 25 11:00:38 2017] [error] [client ::1] (13)Permission denied: An error occurred while opening a resource.  [500, #0]

In the logs.

No error returned though..

Associated revisions

Revision 75317423 (diff)
Added by Benoît PECCATTE over 2 years ago

Fixes #10070: Error when putting uuid.hive in inventory-updates

History

#1

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 4.1.0~beta2 to 4.1.0~beta3
#2

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 4.1.0~beta3 to 4.1.0~rc1
#3

Updated by Nicolas CHARLES over 2 years ago

isn't it an ipv6 issue ?

#4

Updated by Nicolas CHARLES over 2 years ago

Ok, this is because file /var/rudder/inventories/accepted-nodes-updates/uuid.hive already exists, and we cannot replace it

#5

Updated by Nicolas CHARLES over 2 years ago

This is specific 4.1, in earlier version it does work as expected

#6

Updated by François ARMAND over 2 years ago

  • Assignee set to Alexis MOUSSET
#7

Updated by François ARMAND over 2 years ago

  • Tags set to Blocking 4.1
#8

Updated by François ARMAND over 2 years ago

  • Assignee changed from Alexis MOUSSET to Benoît PECCATTE
#9

Updated by Benoît PECCATTE over 2 years ago

This is due to the owner of the file /var/rudder/inventories/accepted-nodes-updates/uuid.hive being root instead of apache.
I still don't know how this owner could change however

#10

Updated by Benoît PECCATTE over 2 years ago

  • Status changed from New to In progress
#11

Updated by Benoît PECCATTE over 2 years ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Benoît PECCATTE to Nicolas CHARLES
  • Pull Request set to https://github.com/Normation/rudder-packages/pull/1275
#12

Updated by Benoît PECCATTE over 2 years ago

  • Status changed from Pending technical review to Pending release
#13

Updated by Vincent MEMBRÉ over 2 years ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 4.1.0~rc1 which was released today.

Also available in: Atom PDF