Project

General

Profile

Actions

Architecture #10362

closed

Negation in "Search nodes" by package doesn't work

Added by Michael Schepp over 7 years ago. Updated about 2 months ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Server components
Target version:
Effort required:
Name check:
Fix check:
Regression:
No

Description

Hi,

I was trying to search for nodes that have a specific software package not installed. It seems that the queries won't get executed correctly. I've tried several different search parameters:

1) Software -> Name -> not equal -> Package-Name (e.g. exim4)
2) Software -> Name -> Not matching Regex -> exim4.*
3) Software -> Name -> Not matching Regex -> ^(exim4$).*
4) Software -> Name -> Regex -> (?!exim4$).*

None of them worked. I guess it shouldn't require much effort to fix, because if the Regex is used correctly it should work.

Feel free to modify the ticket if it's more work to fix or if the severity is wrong.

Best regards,
Michael

Actions #1

Updated by Jonathan CLARKE over 7 years ago

  • Effort required deleted (Small)
Actions #2

Updated by Jonathan CLARKE over 7 years ago

  • User visibility set to Operational - other Techniques | Technique editor | Rudder settings
Actions #3

Updated by Benoît PECCATTE about 7 years ago

  • Priority set to 36
Actions #4

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 4.0.4 to 4.0.5
Actions #5

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 4.0.5 to 4.0.6
  • Priority changed from 36 to 35
Actions #6

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 4.0.6 to 4.0.7
Actions #7

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 4.0.7 to 357
Actions #8

Updated by Benoît PECCATTE almost 7 years ago

  • Priority changed from 35 to 49
Actions #9

Updated by Alexis Mousset almost 7 years ago

  • Target version changed from 357 to 4.1.6
Actions #10

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 4.1.6 to 4.1.7
  • Priority changed from 49 to 48
Actions #11

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 4.1.7 to 4.1.8
Actions #12

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.1.8 to 4.1.9
  • Priority changed from 48 to 46
Actions #13

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.1.9 to 4.1.10
  • Priority changed from 46 to 45
Actions #14

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.1.10 to 4.1.11
  • Priority changed from 45 to 43
Actions #15

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.11 to 4.1.12
Actions #16

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.12 to 4.1.13
Actions #17

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 4.1.13 to 4.1.14
Actions #18

Updated by Benoît PECCATTE almost 6 years ago

  • Target version changed from 4.1.14 to 4.1.15
Actions #19

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.15 to 4.1.16
Actions #20

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.16 to 4.1.17
Actions #21

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.17 to 4.1.18
  • Priority changed from 43 to 0
Actions #22

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.18 to 4.1.19
Actions #23

Updated by Alexis Mousset over 5 years ago

  • Target version changed from 4.1.19 to 4.1.20
Actions #24

Updated by François ARMAND over 5 years ago

  • Target version changed from 4.1.20 to 4.1.21
Actions #25

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.1.21 to 4.1.22
Actions #26

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.1.22 to 4.1.23
Actions #27

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.1.23 to 4.1.24
Actions #28

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 4.1.24 to 588
Actions #29

Updated by Alexis Mousset almost 5 years ago

  • Subject changed from Negation in "Search nodes" doesn't work to Negation in "Search nodes" by package doesn't work
  • Target version changed from 588 to 5.0.13

It may be because the condition is applied to all software, and always matches (as you always have at least one package not names "exim"). We may need more precise criteria for this.

Actions #30

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 5.0.13 to 5.0.14
Actions #31

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.14 to 5.0.15
Actions #32

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.15 to 5.0.16
Actions #33

Updated by Alexis Mousset over 4 years ago

  • Target version changed from 5.0.16 to 5.0.17
Actions #34

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 5.0.17 to 5.0.18
Actions #35

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.18 to 5.0.19
Actions #36

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.19 to 5.0.20
Actions #37

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 5.0.20 to 797
Actions #38

Updated by Benoît PECCATTE almost 3 years ago

  • Target version changed from 797 to 6.1.14
Actions #39

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #40

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #41

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #42

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #43

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #44

Updated by François ARMAND over 2 years ago

  • Tracker changed from Bug to User story
  • Severity deleted (Major - prevents use of part of Rudder | no simple workaround)
  • Priority deleted (0)
Actions #45

Updated by François ARMAND over 2 years ago

  • Tracker changed from User story to Architecture
  • Status changed from New to Backlog
  • User visibility deleted (Operational - other Techniques | Technique editor | Rudder settings)

This is a long standing problem, and to workaround it, we added the possibility to return the opposite of a request (so you can create the query for the software version then invert it). It's a soso work-around, but the root cause implies some deep change in architecture, and will be track at the roadmap level.

Actions #46

Updated by François ARMAND about 2 months ago

  • Status changed from Backlog to Rejected
  • Regression set to No

Closing it since the work around + group composition is reported to be ok for now, and the root cause won't be corrected in a near futur (and we are deeply aware of it).

Actions

Also available in: Atom PDF