Project

General

Profile

Bug #10440

Error when upgrading from Rudder 3.1 to Rudder 4.1 on Debian 8

Added by Nicolas CHARLES over 3 years ago. Updated over 3 years ago.

Status:
Released
Priority:
N/A
Category:
Packaging
Target version:
Severity:
Major - prevents use of part of Rudder | no simple workaround
User visibility:
Operational - other Techniques | Technique editor | Rudder settings
Effort required:
Priority:
36

Description

Mar 16 12:53:25 server apache2[3431]: The apache2 configtest failed. ... (warning).
Mar 16 12:53:25 server apache2[3431]: Output of config test was:
Mar 16 12:53:25 server apache2[3431]: apache2: Syntax error on line 219 of /etc/apache2/apache2.conf: Could not open configuration file /etc/apache2/sites-enabled/rudder-vhost-ssl.conf: No such file or directory
Mar 16 12:53:25 server apache2[3431]: Action 'configtest' failed.
Mar 16 12:53:25 server apache2[3431]: The Apache error log may have more information.

--

Unpacking rudder-webapp (4.1.0~rc2~git201703161159-jessie0) over (3.1.19~rc1~git201703150718-jessie0) ...
dpkg: warning: unable to delete old directory '/opt/rudder/etc/ssl': Directory not empty
dpkg: warning: unable to delete old directory '/var/rudder/inventories/accepted-nodes-updates': Directory not empty

---

INFO: Restarting Apache HTTPd...dpkg: error processing package ncf-api-virtualenv (--configure):
 subprocess installed post-installation script returned error exit status 1

----

*****************************************************************************************
INFO: rudder-server-relay setup complete.                                                
INFO:                                                                                    
INFO: * If you are installing a root server, configuration is automatically done         
INFO: * If you are installing a simple relay, run:                                       
INFO:   '/opt/rudder/bin/rudder-node-to-relay root'          
INFO:   on your root server to complete this node transition to a relay server.          
INFO:   Please look at the documentation for details (Section 'Relay servers')           
*****************************************************************************************
dpkg: dependency problems prevent configuration of rudder-webapp:
 rudder-webapp depends on ncf-api-virtualenv; however:
  Package ncf-api-virtualenv is not configured yet.

dpkg: error processing package rudder-webapp (--configure):
 dependency problems - leaving unconfigured

running again

apt-get install rudder-server-root ncf ncf-api-virtualenv

solves the issue


Related issues

Has duplicate Rudder - Bug #10492: Error during install of Rudder 4.1 on Debian 7 for apache2RejectedActions

Also available in: Atom PDF