Project

General

Profile

Actions

Bug #10462

closed

package verify version (sometimes?) does not check version of packages

Added by Alexis Mousset over 5 years ago. Updated 4 months ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Generic methods
Target version:
Severity:
Major - prevents use of part of Rudder | no simple workaround
UX impact:
User visibility:
Operational - other Techniques | Technique editor | Rudder settings
Effort required:
Priority:
0
Regression:

Description

The package_check_version generic methods does not always checks the precise version of the package, but sometimes only its presence.

This may possibly be fixed by using specific package bodies with a specified version in the package name.


Related issues 1 (0 open1 closed)

Is duplicate of Rudder - Bug #9547: package_install should use another package body when using a specific package versionReleasedNicolas CHARLESActions
Actions #1

Updated by Alexis Mousset over 5 years ago

  • Severity set to Major - prevents use of part of Rudder | no simple workaround
Actions #2

Updated by Fran├žois ARMAND over 5 years ago

  • User visibility set to Operational - other Techniques | Technique editor | Rudder settings
Actions #3

Updated by Alexis Mousset over 5 years ago

  • Priority set to 36

Only happens with old package technique/method.

Actions #4

Updated by Alexis Mousset over 5 years ago

  • Category changed from Generic methods - Package Management to 83
  • Priority changed from 36 to 35
Actions #5

Updated by Alexis Mousset over 5 years ago

  • Is duplicate of Bug #9547: package_install should use another package body when using a specific package version added
Actions #6

Updated by Alexis Mousset over 5 years ago

  • Status changed from New to Rejected
  • Priority changed from 35 to 50

Fixed by #9547.

Actions #7

Updated by Alexis Mousset over 4 years ago

  • Category changed from 83 to Generic methods - Package Management
  • Priority changed from 50 to 43
Actions #8

Updated by Alexis Mousset 4 months ago

  • Target version changed from 0.x to ncf-0.x
  • Priority changed from 43 to 0
Actions #9

Updated by Alexis Mousset 4 months ago

  • Project changed from 41 to Rudder
  • Category changed from Generic methods - Package Management to Generic methods
Actions

Also available in: Atom PDF