Project

General

Profile

Actions

Bug #10548

closed

Rudder documentation and release note don't mention the dependency to Java 1.8 for Rudder 4.1

Added by Nicolas CHARLES about 4 years ago. Updated about 4 years ago.

Status:
Released
Priority:
N/A
Category:
Documentation
Target version:
Severity:
Critical - prevents main use of Rudder | no workaround | data loss | security
User visibility:
Getting started - demo | first install | level 1 Techniques
Effort required:
Priority:
0

Description

Neither the documentation nor the release note state that to upgrade to Rudder 4.1 one need Java 1.8 - which is especially surprising on Debian 7, where Java 8 is not in officials repos


Related issues

Related to Rudder - Architecture #8964: Update documentation to explaine Java8 requirment in Rudder 4.0 Rejected2016-09-07Actions
Related to Rudder tools - Bug #10560: Update changelog to state that Rudder 4.1 needs Java 1.8ReleasedAlexis MOUSSETActions
Actions #1

Updated by Nicolas CHARLES about 4 years ago

  • Related to Architecture #8964: Update documentation to explaine Java8 requirment in Rudder 4.0 added
Actions #2

Updated by Nicolas CHARLES about 4 years ago

  • Status changed from New to In progress
  • Assignee set to Nicolas CHARLES
Actions #3

Updated by Nicolas CHARLES about 4 years ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Nicolas CHARLES to Alexis MOUSSET
  • Pull Request set to https://github.com/Normation/rudder-doc/pull/302
Actions #4

Updated by Nicolas CHARLES about 4 years ago

  • Related to Bug #10560: Update changelog to state that Rudder 4.1 needs Java 1.8 added
Actions #5

Updated by Nicolas CHARLES about 4 years ago

  • Status changed from Pending technical review to Pending release
Actions #6

Updated by Vincent MEMBRÉ about 4 years ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 4.1.1 which was released today.

Actions

Also available in: Atom PDF