Project

General

Profile

Actions

Bug #10643

closed

If node run interval is longer than 5 minutes, there may be "no report" at start of Rudder

Added by Nicolas CHARLES about 7 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Web - Config management
Target version:
Severity:
Major - prevents use of part of Rudder | no simple workaround
UX impact:
User visibility:
Operational - other Techniques | Technique editor | Rudder settings
Effort required:
Priority:
0
Name check:
Fix check:
Regression:

Description

I restarted the web interface, and got a lot of node in no answer, with message

No recent reports have been received for this node in the grace period since the last configuration policy change. This is unexpected. Please check the status of the agent by running 'rudder agent health' on the node. For information, expected node policies are displayed below. Current configuration ID for this node is '20170424-130636-20b8d2eb' (generated on 2017-04-24 13:06:36).

Previous run was a 13:13, and current run was 13:23 (and it was 13:23). It solved itself, but it seems we are missing some runs at start
Happens in 4.1, may happen in earlier version


Related issues 1 (0 open1 closed)

Related to Rudder - Bug #10881: Almost nodes become in "red state" after upgrading from 4.0.2 to 4.1.3RejectedActions
Actions #1

Updated by François ARMAND about 7 years ago

  • Severity set to Major - prevents use of part of Rudder | no simple workaround
  • User visibility set to Operational - other Techniques | Technique editor | Rudder settings
Actions #2

Updated by François ARMAND about 7 years ago

  • Priority changed from 0 to 36
Actions #3

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 4.1.2 to 4.1.3
Actions #4

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 4.1.3 to 4.1.4
Actions #5

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 4.1.4 to 4.1.5
Actions #6

Updated by Alexis Mousset almost 7 years ago

  • Target version changed from 4.1.5 to 4.1.6
  • Priority changed from 36 to 35
Actions #7

Updated by Benoît PECCATTE almost 7 years ago

  • Priority changed from 35 to 51
Actions #8

Updated by Nicolas CHARLES almost 7 years ago

  • Related to Bug #10881: Almost nodes become in "red state" after upgrading from 4.0.2 to 4.1.3 added
Actions #9

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 4.1.6 to 4.1.7
  • Priority changed from 51 to 50
Actions #10

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 4.1.7 to 4.1.8
  • Priority changed from 50 to 49
Actions #11

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.1.8 to 4.1.9
  • Priority changed from 49 to 48
Actions #12

Updated by Benoît PECCATTE over 6 years ago

  • Priority changed from 48 to 47
Actions #13

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.1.9 to 4.1.10
  • Priority changed from 47 to 46
Actions #14

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.1.10 to 4.1.11
  • Priority changed from 46 to 45
Actions #15

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.11 to 4.1.12
  • Priority changed from 45 to 43
Actions #16

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.12 to 4.1.13
Actions #17

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 4.1.13 to 4.1.14
Actions #18

Updated by Benoît PECCATTE almost 6 years ago

  • Target version changed from 4.1.14 to 4.1.15
Actions #19

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.15 to 4.1.16
Actions #20

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.16 to 4.1.17
Actions #21

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.17 to 4.1.18
  • Priority changed from 43 to 0
Actions #22

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.18 to 4.1.19
Actions #23

Updated by Alexis Mousset over 5 years ago

  • Target version changed from 4.1.19 to 4.1.20
Actions #24

Updated by François ARMAND over 5 years ago

  • Target version changed from 4.1.20 to 4.1.21
Actions #25

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.1.21 to 4.1.22
Actions #26

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.1.22 to 4.1.23
Actions #27

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.1.23 to 4.1.24
Actions #28

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 4.1.24 to 588
Actions #29

Updated by Nicolas CHARLES almost 5 years ago

  • Status changed from New to Rejected

i think it was simply because the store run agent could catch up. Rejecting as we fixed a lot of issues around that

Actions #30

Updated by Alexis Mousset over 4 years ago

  • Target version changed from 588 to 4.1.24
Actions

Also available in: Atom PDF