Project

General

Profile

Actions

Bug #10743

closed

Dynamic group search not available on boolean node property value

Added by Janos Mattyasovszky about 7 years ago. Updated over 6 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Web - Nodes & inventories
Target version:
-
Severity:
Minor - inconvenience | misleading | easy workaround
UX impact:
User visibility:
Operational - other Techniques | Technique editor | Rudder settings
Effort required:
Priority:
30
Name check:
Fix check:
Regression:

Description

If a simple node property is added via the GUI, example: "install_fail2ban" is set to "true", this expression is not searchable via a dynamic group query, that is built as "[Properties] [Name=Value] [=] [install_fail2ban=true]". This is probably because "true" is not a string.

It works if the property's value is a string, like "yes".

However, if it's not a boolean, the node property cannot be used in a mustache template with {{#vars.node.properties.install_fail2ban}}.

Current workaround is to create a dynamic group based on the search "install_fail2ban=yes", and use the group's class definition in the mustache template like {{#classes.group_install_fail2ban_software}}.


Related issues 2 (0 open2 closed)

Related to Rudder - Bug #9299: Extend groups search capabilities for complex JSON Properties / JsonPathReleasedVincent MEMBRÉActions
Is duplicate of Rudder - Bug #10599: Impossible to search or build groups based on JSON values in node propertiesReleasedVincent MEMBRÉActions
Actions #1

Updated by François ARMAND about 7 years ago

  • Priority changed from 0 to 17

Seems to be linked to: #9299

Actions #2

Updated by François ARMAND about 7 years ago

  • Related to Bug #9299: Extend groups search capabilities for complex JSON Properties / JsonPath added
Actions #3

Updated by Benoît PECCATTE almost 7 years ago

  • Priority changed from 17 to 32
Actions #4

Updated by Benoît PECCATTE almost 7 years ago

  • Category set to Web - Nodes & inventories
Actions #5

Updated by Benoît PECCATTE over 6 years ago

  • Priority changed from 32 to 30
Actions #6

Updated by François ARMAND over 6 years ago

  • Related to Bug #10599: Impossible to search or build groups based on JSON values in node properties added
Actions #7

Updated by François ARMAND over 6 years ago

  • Status changed from New to Rejected

This one will be corrected by #10599. I'm already closing it, because in all cases #10599 is a superset of that one.

Actions #8

Updated by François ARMAND over 6 years ago

  • Related to deleted (Bug #10599: Impossible to search or build groups based on JSON values in node properties)
Actions #9

Updated by François ARMAND over 6 years ago

  • Is duplicate of Bug #10599: Impossible to search or build groups based on JSON values in node properties added
Actions

Also available in: Atom PDF