Project

General

Profile

Bug #10855

package methods fail when a package providing the desired package is installed

Added by Hamlyn Mootoo about 3 years ago. Updated 22 days ago.

Status:
New
Priority:
N/A
Assignee:
-
Category:
Generic methods - Package Management
Target version:
Pull Request:
Severity:
Minor - inconvenience | misleading | easy workaround
User visibility:
Operational - other Techniques | Technique editor | Rudder settings
Effort required:
Priority:
0

Description

I tried creating a directive from the package manager technique which install the rpm "yum-plugin-downloadonly", but it fails to install. I just took the defaults architecture, version, and package manager. I also tried specifying architecture as "noarch" but that did not work either.

The error is as follows:

E| error packageManagement Package yum-plugin-downlo| Presence of package yum-plugin-downloadonly in any version could not be repaired
E| n/a packageManagement Post-modification script yum-plugin-downlo| No post-modification script was set to run

  1. Summary #####################################################################
    34 components verified in 5 directives
    => 34 components in Enforce mode
    -> 31 compliant
    -> 2 not-applicable
    -> 1 error
    execution time: 7.26s ################################################################################
    [root@rserver outputs]# yum list yum-plugin-downloadonly
    Loaded plugins: product-id, rhui-lb, security, subscription-manager
    This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
    Available Packages
    yum-plugin-downloadonly.noarch 1.1.30-30.el6 rhui-rhel-6-server-rhui-rpms

Files

package_noarch.JPG (140 KB) package_noarch.JPG Hamlyn Mootoo, 2017-06-05 21:18
#1

Updated by Hamlyn Mootoo about 3 years ago

This may be a non-issue. When I tried to install this package manually I got:
root@rserver ~]# yum install yum-plugin-downloadonly
Loaded plugins: product-id, rhui-lb, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Setting up Install Process
Package yum-plugin-downloadonly-1.1.30-30.el6.noarch is obsoleted by yum-3.2.29-81.el6.noarch which is already installed
Nothing to do

This may be causing the issue.

#2

Updated by Alexis MOUSSET about 3 years ago

  • Project changed from Rudder to ncf
  • Subject changed from Package Manager Technique does not install a package with "noarch" architecture to Package Manager methods fail when a package providing the desired package is installed
  • Category changed from Techniques to Generic methods - Package Management
  • Target version set to 1.0
  • Severity changed from Major - prevents use of part of Rudder | no simple workaround to Minor - inconvenience | misleading | easy workaround

It may indeed not be handled correctly. Moving to ncf as the package methods are implemented there, and setting severity to "Minor" as it seems to only fail with obsolete packages.

#3

Updated by François ARMAND about 3 years ago

  • Priority changed from 0 to 17
#4

Updated by Alexis MOUSSET about 3 years ago

  • Target version changed from 1.0 to 1.1
  • Priority changed from 17 to 32
#5

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 1.1 to 4.1.9
  • Priority changed from 32 to 30
#6

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 4.1.9 to 4.1.10
#7

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 4.1.10 to 4.1.11
  • Priority changed from 30 to 29
#8

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 4.1.11 to 4.1.12
  • Priority changed from 29 to 28
#9

Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 4.1.12 to 4.1.13
  • Priority changed from 28 to 27
#10

Updated by Benoît PECCATTE about 2 years ago

  • Target version changed from 4.1.13 to 411
#11

Updated by Benoît PECCATTE about 2 years ago

  • Target version changed from 411 to 4.1.13
#12

Updated by Alexis MOUSSET about 2 years ago

  • Subject changed from Package Manager methods fail when a package providing the desired package is installed to package methods fail when a package providing the desired package is installed

It is because the installed package name does not matched the target package name.

#13

Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 4.1.13 to 4.1.14
#14

Updated by Benoît PECCATTE about 2 years ago

  • Target version changed from 4.1.14 to 4.1.15
#15

Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 4.1.15 to 4.1.16
#16

Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 4.1.16 to 4.1.17
#17

Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 4.1.17 to 4.1.18
  • Priority changed from 27 to 0
#18

Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 4.1.18 to 4.1.19
#19

Updated by Alexis MOUSSET over 1 year ago

  • Target version changed from 4.1.19 to 4.1.20
#20

Updated by François ARMAND over 1 year ago

  • Target version changed from 4.1.20 to 4.1.21
#21

Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 4.1.21 to 4.1.22
#22

Updated by Benoît PECCATTE over 1 year ago

  • Target version changed from 4.1.22 to 5.0.10
#23

Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 5.0.10 to 5.0.11
#24

Updated by Vincent MEMBRÉ about 1 year ago

  • Target version changed from 5.0.11 to 5.0.12
#25

Updated by Vincent MEMBRÉ about 1 year ago

  • Target version changed from 5.0.12 to 5.0.13
#26

Updated by Vincent MEMBRÉ 12 months ago

  • Target version changed from 5.0.13 to 5.0.14
#27

Updated by Vincent MEMBRÉ 11 months ago

  • Target version changed from 5.0.14 to 5.0.15
#28

Updated by Vincent MEMBRÉ 8 months ago

  • Target version changed from 5.0.15 to 5.0.16
#29

Updated by Alexis MOUSSET 6 months ago

  • Target version changed from 5.0.16 to 5.0.17
#30

Updated by Vincent MEMBRÉ 4 months ago

  • Target version changed from 5.0.17 to 5.0.18
#31

Updated by Vincent MEMBRÉ 22 days ago

  • Target version changed from 5.0.18 to 5.0.19

Also available in: Atom PDF