Project

General

Profile

Actions

Bug #10856

closed

Cron service is not correctly managed by technique common

Added by Nicolas CHARLES about 7 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
N/A
Assignee:
-
Category:
System integration
Target version:
Severity:
Minor - inconvenience | misleading | easy workaround
UX impact:
User visibility:
Infrequent - complex configurations | third party integrations
Effort required:
Priority:
21
Name check:
Fix check:
Regression:

Description

Service cron is checked by technique common, in system/common/1.0/cron-setup.st
However, it seems the verification is not totally correct - there's been case of users having malfunctoning cron; and the code to check cron is really smelly (we define the service_name, but simply check for "cron" process name)

We should either check the service using the services generic method (so in 4.1 or more), or have more refined checks on process running and service starting

Not setting the target version, as we need to decide where we need to fix this


Related issues 1 (0 open1 closed)

Related to Rudder - Bug #10771: check-rudder-agent doesn't purge the lmdb file when run via cronReleasedAlexis MoussetActions
Actions #1

Updated by Nicolas CHARLES about 7 years ago

  • Related to Bug #10771: check-rudder-agent doesn't purge the lmdb file when run via cron added
Actions #2

Updated by François ARMAND about 7 years ago

  • Severity set to Minor - inconvenience | misleading | easy workaround
  • User visibility set to Infrequent - complex configurations | third party integrations
  • Priority changed from 0 to 6

So, the actual problem is more that when cron is stopped by hand, we never restart it.

We put minor because a manual run workaround the problem, and it is likelly that an ops will see a non running cron as a system smell.

Actions #3

Updated by Benoît PECCATTE almost 7 years ago

  • Priority changed from 6 to 22
Actions #4

Updated by Benoît PECCATTE over 6 years ago

  • Priority changed from 22 to 20
Actions #5

Updated by Nicolas CHARLES almost 5 years ago

  • Target version set to 5.0.13
  • Priority changed from 20 to 18

still true

Actions #6

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 5.0.13 to 5.0.14
Actions #7

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.14 to 5.0.15
Actions #8

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.15 to 5.0.16
Actions #9

Updated by Alexis Mousset over 4 years ago

  • Target version changed from 5.0.16 to 5.0.17
Actions #10

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 5.0.17 to 5.0.18
Actions #11

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.18 to 5.0.19
Actions #12

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.19 to 5.0.20
  • Priority changed from 18 to 19
Actions #13

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 5.0.20 to 797
Actions #14

Updated by Benoît PECCATTE almost 3 years ago

  • Target version changed from 797 to 6.1.14
  • Priority changed from 19 to 20
Actions #15

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #16

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #17

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #18

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
  • Priority changed from 20 to 21
Actions #19

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #20

Updated by François ARMAND over 2 years ago

  • Status changed from New to Resolved

It is corrected in 7.0.

Actions

Also available in: Atom PDF