Project

General

Profile

Actions

Bug #11443

closed

Make Rudder works with Java 9

Added by François ARMAND over 6 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Architecture - Dependencies
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Name check:
Fix check:
Regression:

Description

This is the umbrella tocket to follow the porting effort needed to make Rudder works for Java 9. The path will likelly be interesting.

I'm targetting 4.1 for now because I'm an optimistic person, but more realistically, it will need some big changes, and so a new major.


Subtasks 1 (0 open1 closed)

Architecture #11444: Java 9: Rudder test fails because of JS engineRejectedActions

Related issues 1 (0 open1 closed)

Related to Rudder - Bug #12557: Java 9 / Java 10 compatibility: javax/xml/bind removedReleasedFrançois ARMANDActions
Actions #1

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.1.8 to 4.1.9
Actions #2

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.9 to 4.1.10
Actions #3

Updated by Benoît PECCATTE about 6 years ago

  • Target version changed from 4.1.10 to Ideas (not version specific)
Actions #4

Updated by Alexis Mousset over 5 years ago

  • Related to Bug #12557: Java 9 / Java 10 compatibility: javax/xml/bind removed added
Actions #5

Updated by Alexis Mousset over 5 years ago

  • Status changed from New to Pending technical review

Java 9 is supported since Rudder 4.3, won't be backported to 4.1. Closing.

Actions #6

Updated by Alexis Mousset over 5 years ago

  • Status changed from Pending technical review to In progress
Actions #7

Updated by Alexis Mousset over 5 years ago

  • Tracker changed from Architecture to Bug
  • Status changed from In progress to Pending release
  • Priority set to 0
Actions #8

Updated by Alexis Mousset over 5 years ago

  • Target version changed from Ideas (not version specific) to 4.3.7
Actions #9

Updated by Alexis Mousset over 5 years ago

  • Status changed from Pending release to New
Actions #10

Updated by François ARMAND over 5 years ago

Actually it was fairly simple and we just had to wait for lib to correct some minor problems (and change a couple of rights for our JS exec jail).

Actions #11

Updated by François ARMAND over 5 years ago

  • Status changed from New to Rejected
Actions

Also available in: Atom PDF