Project

General

Profile

Actions

Bug #11680

closed

When we shift-reload the "Compliance reports" in nodes, there is a javascript error, and we don't have compliance that's show up

Added by Nicolas CHARLES over 6 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
N/A
Category:
Web - UI & UX
Target version:
Severity:
Minor - inconvenience | misleading | easy workaround
UX impact:
User visibility:
Getting started - demo | first install | level 1 Techniques
Effort required:
Very Small
Priority:
0
Name check:
Fix check:
Regression:

Description

On the node details, compliance report, if we shift-reload (not simply reload) the page, the compliance won't show up
JS error is

TypeError: e[i] is undefined[En savoir plus]  datatables.min.js:77:437
TypeError: p.nTHead is null[En savoir plus]


Related issues 1 (0 open1 closed)

Related to Rudder - Bug #12388: Node agent schedule cannot be changed due to a JS ErrorReleasedFrançois ARMANDActions
Actions #1

Updated by Benoît PECCATTE over 6 years ago

  • Severity set to Minor - inconvenience | misleading | easy workaround
  • User visibility set to Getting started - demo | first install | level 1 Techniques
  • Priority changed from 0 to 50
Actions #2

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.1.9 to 4.1.10
Actions #3

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.1.10 to 4.1.11
  • Priority changed from 50 to 48
Actions #4

Updated by Nicolas CHARLES about 6 years ago

  • Related to Bug #12388: Node agent schedule cannot be changed due to a JS Error added
Actions #5

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.11 to 4.1.12
  • Priority changed from 48 to 47
Actions #6

Updated by Raphael GAUTHIER about 6 years ago

  • Status changed from New to In progress
Actions #7

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.12 to 4.1.13
  • Priority changed from 47 to 46
Actions #8

Updated by Benoît PECCATTE about 6 years ago

  • Target version changed from 4.1.13 to 411
Actions #9

Updated by Benoît PECCATTE about 6 years ago

  • Target version changed from 411 to 4.1.13
Actions #10

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 4.1.13 to 4.1.14
  • Priority changed from 46 to 45
Actions #11

Updated by Benoît PECCATTE almost 6 years ago

  • Target version changed from 4.1.14 to 4.1.15
  • Priority changed from 45 to 44
Actions #12

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.15 to 4.1.16
  • Priority changed from 44 to 42
Actions #13

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.16 to 4.1.17
Actions #14

Updated by Raphael GAUTHIER over 5 years ago

  • Priority changed from 42 to 0
Actions #15

Updated by Raphael GAUTHIER over 5 years ago

  • Status changed from In progress to Rejected

I can't reproduce this bug. Feel free to reopen it if it still appears.
Rejecting

Actions #16

Updated by Alexis Mousset over 5 years ago

  • Status changed from Rejected to New

I still reproduce in 5.0.2, reopening.

Actions #17

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.17 to 4.1.18
Actions #18

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.18 to 4.1.19
Actions #19

Updated by Alexis Mousset over 5 years ago

  • Target version changed from 4.1.19 to 4.1.20
Actions #20

Updated by François ARMAND over 5 years ago

  • Target version changed from 4.1.20 to 4.1.21
Actions #21

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.1.21 to 4.1.22
Actions #22

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.1.22 to 4.1.23
Actions #23

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.1.23 to 4.1.24
Actions #24

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 4.1.24 to 588
Actions #25

Updated by Alexis Mousset almost 5 years ago

  • Target version changed from 588 to 5.0.13
Actions #26

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 5.0.13 to 5.0.14
Actions #27

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.14 to 5.0.15
Actions #28

Updated by François ARMAND over 4 years ago

  • Effort required set to Very Small

Budget: very small: reproduce it with someone able to understand the cause (even if correction is very hard, at least we don't keep open ticket with no possibility to do anything on them)

Actions #29

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.15 to 5.0.16
Actions #30

Updated by Alexis Mousset over 4 years ago

  • Target version changed from 5.0.16 to 5.0.17
Actions #31

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 5.0.17 to 5.0.18
Actions #32

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.18 to 5.0.19
Actions #33

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.19 to 5.0.20
Actions #34

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 5.0.20 to 797
Actions #35

Updated by Benoît PECCATTE almost 3 years ago

  • Target version changed from 797 to 6.1.14
Actions #36

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #37

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #38

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #39

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #40

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #41

Updated by François ARMAND over 2 years ago

  • Status changed from New to Resolved

This is not the case anymore in 7.0.

Actions

Also available in: Atom PDF