Project

General

Profile

Actions

User story #11753

closed

Deprecate API v7 and remove API v5 and v6

Added by François ARMAND about 5 years ago. Updated about 5 years ago.

Status:
Released
Priority:
N/A
Category:
API
Target version:
UX impact:
Suggestion strength:
User visibility:
Effort required:
Regression:

Description

API v5 (resp v6) is linked to Rudder 3.0 (resp 3.1). It was deprecated in Rudder 4.1 (previous LTS) and so can be removed in 4.2.
We can deprecate v7 because it was added in version n-3 and all API version are deprecated up to that version.

This ticket is only about no more exposing the rudder/api/5,6/... version. Of course, endpoints added in these version are still accessible throught higher version number or latest.


Related issues 1 (0 open1 closed)

Related to Rudder - User story #9836: Deprecate API v5, v6 and v7, and remove API v2,3,4ReleasedVincent MEMBRÉ2016-12-21Actions
Actions #1

Updated by François ARMAND about 5 years ago

  • Related to User story #9836: Deprecate API v5, v6 and v7, and remove API v2,3,4 added
Actions #2

Updated by François ARMAND about 5 years ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from François ARMAND to Vincent MEMBRÉ
  • Pull Request set to https://github.com/Normation/rudder/pull/1787
Actions #3

Updated by François ARMAND about 5 years ago

  • Status changed from Pending technical review to Pending release
Actions #4

Updated by Vincent MEMBRÉ about 5 years ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 4.2.3 which was released today.

Actions

Also available in: Atom PDF