Project

General

Profile

Actions

Bug #11826

closed

Not useful error message on no NCF write access

Added by Janos Mattyasovszky over 6 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
N/A
Assignee:
-
Category:
Web - Technique editor
Target version:
Severity:
Minor - inconvenience | misleading | easy workaround
UX impact:
User visibility:
Operational - other Techniques | Technique editor | Rudder settings
Effort required:
Very Small
Priority:
0
Name check:
Fix check:
Regression:

Description

I tried to use the NCF editor and save something.

I got the error.

An Error occured! Error while creating Technique 'Aaaa'

In the webapp logs I have finally found:

[2017-12-05 16:19:41] ERROR com.normation.rudder.web.rest.RestAuthentication - Authentication API forbids write access to Techniques for user XXXXXX

The user-facing error could be a little bit more descriptive...

Actions #1

Updated by Benoît PECCATTE over 6 years ago

  • User visibility changed from First impressions of Rudder to Operational - other Techniques | Technique editor | Rudder settings
  • Priority changed from 80 to 32

The error should be reported by ncf since the api should return a 403.

Actions #2

Updated by Nicolas CHARLES almost 5 years ago

  • Target version set to 5.0.13
  • Priority changed from 32 to 0

Retargeting to 5.0 to validate if it's still the case

Actions #3

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 5.0.13 to 5.0.14
Actions #4

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.14 to 5.0.15
Actions #5

Updated by François ARMAND over 4 years ago

  • Effort required set to Very Small

budget: very small: it should be corrected by now, try to reproduce and close is the error cause is displayed.

Actions #6

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.15 to 5.0.16
Actions #7

Updated by Alexis Mousset over 4 years ago

  • Target version changed from 5.0.16 to 5.0.17
Actions #8

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 5.0.17 to 5.0.18
Actions #9

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.18 to 5.0.19
Actions #10

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.19 to 5.0.20
Actions #11

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 5.0.20 to 797
Actions #12

Updated by Benoît PECCATTE almost 3 years ago

  • Target version changed from 797 to 6.1.14
Actions #13

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #14

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #15

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #16

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #17

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #18

Updated by François ARMAND over 2 years ago

  • Status changed from New to Resolved

Error are now correctly reported.

Actions

Also available in: Atom PDF