Project

General

Profile

Actions

Bug #12071

closed

Missing key for agent Community with Rudder 4.3 (at least on SLES)

Added by Nicolas CHARLES over 6 years ago. Updated about 6 years ago.

Status:
Rejected
Priority:
N/A
Category:
System techniques
Target version:
Severity:
Minor - inconvenience | misleading | easy workaround
UX impact:
User visibility:
Getting started - demo | first install | level 1 Techniques
Effort required:
Priority:
50
Name check:
Fix check:
Regression:

Description

My SLES inventories, on Rudder 4.3, were all missing the RUDDER section
Somehow, it fixed itself, but my log contains

[2018-01-31 03:13:43] INFO  com.normation.inventory.provisioning.endpoint.FusionReportEndpoint - New input inventory: 'agent1-de42cb79-8efb-46a2-aba7-be87bb7feb28.ocs'
[2018-01-31 03:13:43] ERROR com.normation.inventory.provisioning.fusion.RudderAgentNameParsing - No key for agent Community defined, a key is mandatory
[2018-01-31 03:13:44] INFO  com.normation.inventory.provisioning.endpoint.FusionReportEndpoint - Inventory 'agent1-de42cb79-8efb-46a2-aba7-be87bb7feb28.ocs' parsed in 695 milliseconds ms, now checking signature
[2018-01-31 03:13:44] INFO  com.normation.inventory.provisioning.endpoint.FusionReportEndpoint - Inventory 'agent1-de42cb79-8efb-46a2-aba7-be87bb7feb28.ocs' signature checked in 213 milliseconds ms, now saving
[2018-01-31 03:13:44] INFO  com.normation.inventory.provisioning.endpoint.FusionReportEndpoint - New input inventory: 'relay-1aa7fbf7-2868-4676-9c25-c77531abc9e8.ocs'
[2018-01-31 03:13:44] ERROR com.normation.inventory.provisioning.fusion.RudderAgentNameParsing - No key for agent Community defined, a key is mandatory
[2018-01-31 03:13:45] INFO  com.normation.inventory.provisioning.endpoint.FusionReportEndpoint - Inventory 'relay-1aa7fbf7-2868-4676-9c25-c77531abc9e8.ocs' parsed in 636 milliseconds ms, now checking signature
[2018-01-31 03:13:45] INFO  com.normation.inventory.provisioning.endpoint.FusionReportEndpoint - Inventory 'relay-1aa7fbf7-2868-4676-9c25-c77531abc9e8.ocs' signature checked in 35 milliseconds ms, now saving
[2018-01-31 03:13:45] INFO  com.normation.inventory.provisioning.endpoint.FusionReportEndpoint - New input inventory: 'server-root.ocs'
[2018-01-31 03:13:45] ERROR com.normation.inventory.provisioning.fusion.RudderAgentNameParsing - No key for agent Community defined, a key is mandatory
[2018-01-31 03:13:45] INFO  com.normation.inventory.provisioning.endpoint.FusionReportEndpoint - Inventory 'server-root.ocs' parsed in 377 milliseconds ms, now checking signature
[2018-01-31 03:13:45] INFO  com.normation.inventory.provisioning.endpoint.FusionReportEndpoint - Report file processed in 1 second and 427 milliseconds ms

they seem to have been correctly accepted - nothing in failed, nor any error message on the agent side


Related issues 2 (0 open2 closed)

Related to Rudder - Bug #11635: Error message when accepting an inventoryRejectedFrançois ARMANDActions
Related to Rudder - Bug #11702: Error message when accepting an inventoryRejectedActions
Actions #1

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.3.0~beta1 to 4.3.0~rc1
Actions #2

Updated by Benoît PECCATTE over 6 years ago

  • Severity set to Critical - prevents main use of Rudder | no workaround | data loss | security
  • User visibility set to Getting started - demo | first install | level 1 Techniques
  • Priority changed from 0 to 94

Do you have an failing inventory ?

Actions #3

Updated by Nicolas CHARLES over 6 years ago

  • Related to Bug #11635: Error message when accepting an inventory added
Actions #4

Updated by Benoît PECCATTE over 6 years ago

  • Severity changed from Critical - prevents main use of Rudder | no workaround | data loss | security to Minor - inconvenience | misleading | easy workaround
  • Priority changed from 94 to 50

Self fixing

Actions #5

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.3.0~rc1 to 4.3.0~rc2
Actions #6

Updated by François ARMAND about 6 years ago

  • Translation missing: en.field_tag_list set to Blocking 4.3

It needs to be corrected before final, else it will leads to a lot of false positive in future bug reports.

Actions #7

Updated by Benoît PECCATTE about 6 years ago

  • Assignee set to Nicolas CHARLES

Seems to have disapeared, we need a recheck

Actions #8

Updated by Nicolas CHARLES about 6 years ago

  • Status changed from New to Rejected

Cannot reproduce

Actions #9

Updated by François ARMAND over 5 years ago

  • Related to Bug #11702: Error message when accepting an inventory added
Actions

Also available in: Atom PDF