Project

General

Profile

Actions

Bug #12307

closed

Broken info log in ncf with initial policies

Added by Alexis Mousset about 6 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
System techniques
Target version:
Severity:
Minor - inconvenience | misleading | easy workaround
UX impact:
User visibility:
Infrequent - complex configurations | third party integrations
Effort required:
Small
Priority:
34
Name check:
Fix check:
Regression:

Description

R: @@@@log_info@@@@Check postgresql process@@None@@2018-03-29 08:28:09+00:00##root@#Check if the service postgres:.* writer process is started using ps was correct
R: @@@@log_info@@@@Check postgresql process@@None@@2018-03-29 08:28:09+00:00##root@#Ensure that service postgresql is running was correct
E| compliant     server-roles              Check postgresql process                     Check postgresql process running was correct
R: [INFO] Executing is-enabled on postgresql using the systemctl method
R: @@@@log_info@@@@Check postgresql boot script@@None@@2018-03-29 08:28:09+00:00##root@#Check if service postgresql is started at boot was correct
R: @@@@log_info@@@@Check postgresql boot script@@None@@2018-03-29 08:28:09+00:00##root@#Ensure service postgresql is started at boot was correct
E| compliant     server-roles              Check postgresql boot sc|                    Check postgresql boot starting parameters was correct
E| compliant     Common                    Binaries update                              The agent binaries in /var/rudder/cfengine-community/bin are up to date
warning  12 reports were not parsable.

Related issues 1 (0 open1 closed)

Related to Rudder - Bug #14601: Broken initial promises on a serverRejectedActions
Actions #1

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.3.0~rc2 to 4.3.0~rc3
Actions #2

Updated by François ARMAND about 6 years ago

  • Translation missing: en.field_tag_list set to Blocking 4.3
Actions #3

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.3.0~rc3 to 4.3.0
Actions #4

Updated by François ARMAND about 6 years ago

  • Translation missing: en.field_tag_list deleted (Blocking 4.3)
  • Severity set to Minor - inconvenience | misleading | easy workaround
  • User visibility set to Infrequent - complex configurations | third party integrations
  • Priority changed from 0 to 22

This one only happen if:

- you install package,
- and immediately after that, before a policy generation may happen, you interactively execute the agent.

There is no consequences but the message that can be misleading. I'm qualifying the problem as "infrequent", because the set of condition is not that common to gather. It is clearly not blocking for 4.3-final.

Actions #5

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.3.0 to 4.3.1
Actions #6

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.3.1 to 4.3.2
Actions #7

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.3.2 to 410
  • Priority changed from 22 to 21
Actions #8

Updated by Benoît PECCATTE about 6 years ago

  • Target version changed from 410 to 4.3.2
Actions #9

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.3.2 to 4.3.3
Actions #10

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 4.3.3 to 4.3.4
Actions #11

Updated by Benoît PECCATTE almost 6 years ago

  • Target version changed from 4.3.4 to 4.3.5
Actions #12

Updated by François ARMAND over 5 years ago

  • Priority changed from 21 to 20
Actions #13

Updated by Benoît PECCATTE over 5 years ago

  • Effort required set to Small
  • Priority changed from 20 to 34

It seems to be an initial promise report format error

Actions #14

Updated by Alexis Mousset over 5 years ago

Yes, this is due to missing reporting context that breaks expected report format.

Actions #15

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.3.5 to 4.3.6
Actions #16

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.3.6 to 4.3.7
Actions #17

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.3.7 to 4.3.8
  • Priority changed from 34 to 33
Actions #18

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.3.8 to 4.3.9
  • Priority changed from 33 to 32
Actions #19

Updated by Alexis Mousset over 5 years ago

  • Target version changed from 4.3.9 to 4.3.10
Actions #20

Updated by François ARMAND over 5 years ago

  • Target version changed from 4.3.10 to 4.3.11
  • Priority changed from 32 to 31
Actions #21

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.3.11 to 4.3.12
Actions #22

Updated by Nicolas CHARLES about 5 years ago

  • Related to Bug #14601: Broken initial promises on a server added
Actions #23

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.3.12 to 4.3.13
Actions #24

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.3.13 to 4.3.14
Actions #25

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 4.3.14 to 587
Actions #26

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 587 to 4.3.14
Actions #27

Updated by Alexis Mousset almost 5 years ago

  • Target version changed from 4.3.14 to 5.0.13
Actions #28

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 5.0.13 to 5.0.14
Actions #29

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.14 to 5.0.15
Actions #30

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.15 to 5.0.16
Actions #31

Updated by Alexis Mousset over 4 years ago

  • Target version changed from 5.0.16 to 5.0.17
Actions #32

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 5.0.17 to 5.0.18
Actions #33

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.18 to 5.0.19
Actions #34

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.19 to 5.0.20
Actions #35

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 5.0.20 to 797
Actions #36

Updated by Benoît PECCATTE almost 3 years ago

  • Target version changed from 797 to 6.1.14
  • Priority changed from 31 to 32
Actions #37

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #38

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #39

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #40

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
  • Priority changed from 32 to 33
Actions #41

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #42

Updated by Alexis Mousset over 2 years ago

  • Status changed from New to Rejected
  • Priority changed from 33 to 34

does not exist anymore.

Actions

Also available in: Atom PDF