Project

General

Profile

Actions

User story #12426

closed

Use the new class_prefix for service methods

Added by Alexis Mousset over 6 years ago. Updated about 2 years ago.

Status:
Rejected
Priority:
N/A
Category:
Generic methods
Target version:
UX impact:
Suggestion strength:
User visibility:
Effort required:
Name check:
Fix check:
Regression:

Description

Clean the has_promiser_stack usage too.


Related issues 3 (0 open3 closed)

Related to Rudder - User story #12414: Make reporting work when targeting several time the same item with several generic methodReleasedAlexis MoussetActions
Related to Rudder - Bug #13202: error message in output of rudder 4.3 - 'default:_log_v3.class_prefix' contains a reference to itself, '${class_prefix}'ReleasedActions
Is duplicate of Rudder - Bug #13220: fix reporting in services methods in rudder 4.3 to support multi-reportingReleasedAlexis MoussetActions
Actions #1

Updated by Alexis Mousset over 6 years ago

  • Status changed from New to In progress
Actions #2

Updated by Alexis Mousset over 6 years ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Alexis Mousset to Nicolas CHARLES
  • Pull Request set to https://github.com/Normation/ncf/pull/736
Actions #3

Updated by François ARMAND over 6 years ago

  • Translation missing: en.field_tag_list set to Blocking 4.3
Actions #4

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.3.0 to 4.3.1
Actions #5

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.3.1 to 4.3.2
Actions #6

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.3.2 to 410
Actions #7

Updated by Benoît PECCATTE about 6 years ago

  • Target version changed from 410 to 4.3.2
Actions #8

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.3.2 to 4.3.3
Actions #9

Updated by Rudder Quality Assistant about 6 years ago

  • Assignee changed from Nicolas CHARLES to Alexis Mousset
Actions #10

Updated by Alexis Mousset about 6 years ago

  • Parent task deleted (#12414)
Actions #11

Updated by Alexis Mousset about 6 years ago

  • Status changed from Pending technical review to New
Actions #12

Updated by Alexis Mousset about 6 years ago

  • Related to User story #12414: Make reporting work when targeting several time the same item with several generic method added
Actions #13

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.3.3 to 4.3.4
Actions #14

Updated by Benoît PECCATTE almost 6 years ago

  • Target version changed from 4.3.4 to 4.3.5
Actions #15

Updated by Nicolas CHARLES almost 6 years ago

  • Related to Bug #13202: error message in output of rudder 4.3 - 'default:_log_v3.class_prefix' contains a reference to itself, '${class_prefix}' added
Actions #16

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 4.3.5 to 4.3.6
Actions #17

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.3.6 to 4.3.7
Actions #18

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.3.7 to 4.3.8
Actions #19

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.3.8 to 4.3.9
Actions #20

Updated by Alexis Mousset over 5 years ago

  • Target version changed from 4.3.9 to 4.3.10
Actions #21

Updated by François ARMAND over 5 years ago

  • Target version changed from 4.3.10 to 4.3.11
Actions #22

Updated by Nicolas CHARLES over 5 years ago

  • Status changed from New to Rejected

this has been done in #13220

Actions #23

Updated by Nicolas CHARLES over 5 years ago

  • Is duplicate of Bug #13220: fix reporting in services methods in rudder 4.3 to support multi-reporting added
Actions #24

Updated by Alexis Mousset about 2 years ago

  • Project changed from 41 to Rudder
  • Category changed from Generic methods - Service Management to Generic methods
Actions

Also available in: Atom PDF