Project

General

Profile

Bug #12475

Technique Inventory is deleted when upgrading from 4.1 to 4.3

Added by Nicolas CHARLES about 2 years ago. Updated about 2 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
-
Target version:
Pull Request:
Severity:
User visibility:
Effort required:
Priority:
0

Description

When upgrading from 4.1 to 4.3, on debian 9, I get the following message

[2018-04-17 18:17:13] DEBUG com.normation.rudder.services.policies.PromiseGenerationServiceImpl - Pre-policy-generation modules hooks in 1 ms, start getting all generation related data.
[2018-04-17 18:17:14] DEBUG com.normation.rudder.services.policies.PromiseGenerationServiceImpl - All relevant information fetched in 837 ms, start names historization.
[2018-04-17 18:17:14] INFO  com.normation.cfclerk.services.impl.TechniqueRepositoryImpl - Reloading technique library, found modified technique(s): ['common': updated (1.0: VersionUpdated)], ['server-roles': updated (1.0: VersionUpdated)]
, ['test_technique': updated (1.0: VersionUpdated)], ['distributePolicy': updated (1.0: VersionAdded)], ['inventory': deleted (1.0)]


iq:q:q

somehow, it deleted inventory technique


Related issues

Related to Rudder - Bug #12474: root node disapeared while upgrading from 4.1 to 4.3 on debian 9ReleasedVincent MEMBRÉActions
#1

Updated by Nicolas CHARLES about 2 years ago

  • Related to Bug #12474: root node disapeared while upgrading from 4.1 to 4.3 on debian 9 added
#2

Updated by Nicolas CHARLES about 2 years ago

It seems to be caused by #12474

#3

Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 4.3.1 to 4.3.2
#4

Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 4.3.2 to 410
#5

Updated by Benoît PECCATTE about 2 years ago

We need to try to reproduce this

#6

Updated by Benoît PECCATTE about 2 years ago

  • Target version changed from 410 to 4.3.2
#7

Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 4.3.2 to 4.3.3
#8

Updated by Benoît PECCATTE about 2 years ago

  • Status changed from New to Rejected

Cannot reproduce, feel free to reopen if needed

Also available in: Atom PDF