Project

General

Profile

Actions

Bug #12535

closed

Variable expansion in cron technique

Added by Jean Cardona about 6 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Techniques
Target version:
-
Severity:
Major - prevents use of part of Rudder | no simple workaround
UX impact:
User visibility:
Operational - other Techniques | Rudder settings | Plugins
Effort required:
Priority:
46
Name check:
Fix check:
Regression:

Description

If I use a "generic variable definition" in a new cron entry, it is not expanded.
For example, this:

/usr/bin/barman backup ${generic_variable_definition.barmanhostname} >/dev/null 2>&1

results in a file containing:

/usr/bin/barman backup ${generic_variable_definition.barmanhostname} >/dev/null 2>&1

instead of, for example:

/usr/bin/barman backup test.local >/dev/null 2>&1
Actions #1

Updated by Benoît PECCATTE about 6 years ago

Did you double check that the variable name and prefix is correct ? it is easy to make a mistake on variable names.

Actions #2

Updated by Benoît PECCATTE about 6 years ago

Hello jean, any news on that ?

Actions #3

Updated by Jean Cardona about 6 years ago

Hello, sorry I missed the first notification.
I am certain I double checked the variable name and prefix.

Actions #4

Updated by Benoît PECCATTE about 6 years ago

Can you check the generated files on the node.
The variable definition should be in /var/rudder/cfengine-community/inputs/genericVariableDefinition/*/genericVariableDefinition.cf

@
bundle common generic_variable_definition {

vars:
"myvar" string => "myvalue",
policy => "overridable";

}
@

If it's not there, either there is a generation problem or your variable directive is not applied to your node.

If its there, we may have to look at the cron technique.

Actions #5

Updated by François ARMAND over 5 years ago

Hello @Jean, were you able to check the content of var/rudder/cfengine-community/inputs/genericVariableDefinition/*/genericVariableDefinition.cf ?

Actions #6

Updated by Benoît PECCATTE over 5 years ago

  • Effort required set to Medium
Actions #7

Updated by François ARMAND about 5 years ago

  • User visibility set to Operational - other Techniques | Rudder settings | Plugins
  • Priority changed from 0 to 29
Actions #8

Updated by François ARMAND about 5 years ago

  • Effort required deleted (Medium)
  • Priority changed from 29 to 43
Actions #9

Updated by François ARMAND over 2 years ago

  • Status changed from New to Rejected
  • Priority changed from 43 to 46

Closing it because we don't have enough info to do something.

Actions

Also available in: Atom PDF