Project

General

Profile

Bug #12664

Remove unnecessary conflict dependency with openjdk 9 on debian

Added by François ARMAND 11 months ago. Updated 5 months ago.

Status:
Released
Priority:
N/A
Category:
Packaging
Target version:
Severity:
Minor - inconvenience | misleading | easy workaround
User visibility:
Getting started - demo | first install | level 1 Techniques
Effort required:
Very Small
Priority:
0

Description

For now, if we try to install Java 9/10, it force desinstall rudder-jetty (at least on ubuntu).

For rudder 4.3, we need to allows Java 9 and 10.


Related issues

Related to Rudder - Bug #12557: Java 9 / Java 10 compatibility: javax/xml/bind removedReleasedActions
Copied to Rudder - Bug #13896: Change packaging to allow openjdk > 8 ReleasedActions

Associated revisions

Revision 2f6e6e4b (diff)
Added by Benoît PECCATTE 5 months ago

Fixes #12664: Java 9 / Java 10 compatibility: change packaging to allow these version

History

#1

Updated by François ARMAND 11 months ago

  • Related to Bug #12557: Java 9 / Java 10 compatibility: javax/xml/bind removed added
#2

Updated by Benoît PECCATTE 11 months ago

  • Severity set to Minor - inconvenience | misleading | easy workaround
  • User visibility set to Getting started - demo | first install | level 1 Techniques
  • Priority changed from 0 to 50
#3

Updated by Benoît PECCATTE 11 months ago

  • Target version changed from 410 to 4.3.2
#4

Updated by Vincent MEMBRÉ 11 months ago

  • Target version changed from 4.3.2 to 4.3.3
#5

Updated by Vincent MEMBRÉ 9 months ago

  • Target version changed from 4.3.3 to 4.3.4
#6

Updated by Benoît PECCATTE 9 months ago

  • Target version changed from 4.3.4 to 4.3.5
  • Priority changed from 50 to 49
#7

Updated by Benoît PECCATTE 6 months ago

  • Effort required set to Small
  • Priority changed from 49 to 62
#8

Updated by Vincent MEMBRÉ 6 months ago

  • Target version changed from 4.3.5 to 4.3.6
#9

Updated by Vincent MEMBRÉ 5 months ago

  • Target version changed from 4.3.6 to 4.3.7
  • Priority changed from 62 to 61
#10

Updated by Benoît PECCATTE 5 months ago

  • Effort required changed from Small to Very Small
  • Priority changed from 61 to 0
#11

Updated by Benoît PECCATTE 5 months ago

  • Status changed from New to In progress
  • Assignee set to Benoît PECCATTE
#12

Updated by Benoît PECCATTE 5 months ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Benoît PECCATTE to Alexis MOUSSET
  • Pull Request set to https://github.com/Normation/rudder-packages/pull/1723
#13

Updated by Rudder Quality Assistant 5 months ago

  • Assignee changed from Alexis MOUSSET to Benoît PECCATTE
#14

Updated by Benoît PECCATTE 5 months ago

  • Status changed from Pending technical review to Pending release
#15

Updated by François ARMAND 5 months ago

  • Subject changed from Java 9 / Java 10 compatibility: change packaging to allow these version to Remove unnecessary conflict dependency with openjdk 9 on debian

The proposed correction only removed the conflict with java9, it does not allows java 9/10/11. I'm renaming that one and open a new ticket for java 10/11.

#16

Updated by François ARMAND 5 months ago

  • Copied to Bug #13896: Change packaging to allow openjdk > 8 added
#17

Updated by Vincent MEMBRÉ 5 months ago

  • Status changed from Pending release to Released
This bug has been fixed in Rudder 4.3.7 and 5.0.3 which were released today.
Changelog
Changelog

Also available in: Atom PDF