Project

General

Profile

Bug #12705

Archive API always tells "group" even for other objects

Added by Pierre HAY 12 months ago. Updated 10 months ago.

Status:
Released
Priority:
N/A
Category:
API
Target version:
Severity:
Minor - inconvenience | misleading | easy workaround
User visibility:
Operational - other Techniques | Technique editor | Rudder settings
Effort required:
Priority:
32

Description

Wrong JSON response on the listing archives endpoints.

Associated revisions

Revision 95d09b8e (diff)
Added by Pierre Hay 12 months ago

Fixes #12705: API : correct response

History

#1

Updated by Pierre HAY 12 months ago

  • Status changed from New to In progress
#2

Updated by Benoît PECCATTE 12 months ago

  • User visibility set to Operational - other Techniques | Technique editor | Rudder settings
  • Priority changed from 0 to 32

You could write a little more details in the issue

#3

Updated by Benoît PECCATTE 12 months ago

  • Category set to API
#4

Updated by Pierre HAY 12 months ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Pierre HAY to Vincent MEMBRÉ
  • Pull Request set to https://github.com/Normation/rudder/pull/1951
#5

Updated by Anonymous 12 months ago

  • Status changed from Pending technical review to Pending release
#6

Updated by François ARMAND 12 months ago

  • Subject changed from API : correct response to Archive API always tells "group" even for other objects
#7

Updated by Vincent MEMBRÉ 10 months ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 4.1.13, 4.2.7 and 4.3.3 which were released today.

Also available in: Atom PDF