Project

General

Profile

Actions

Bug #12808

closed

Rudder 4.3 missing important features for plugins, especially ACL one

Added by François ARMAND over 4 years ago. Updated over 4 years ago.

Status:
Released
Priority:
N/A
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Regression:

Description

To solve the parent task #12203, we need to be able to communicate back and forth API ACL information between Rudder backend and front end.

We can't do that now because:

- the event log are not correct (missing elements, not handling all cases)
- API does not send the action type for the path

Moreover, the current architecture force us to do some changes in the existing angularjs code to make what we want works.

There is also several missing point regarding plugin that need to be address (and it's hard to split in several parts given the bounds between each commit):

- we miss a way to declare if a plugin has an API (#12828)
- plugin management should be more based on convention / we should do more in boot/initPlugin (standard log line, standard registring of "toserver" resources)
- we need a common, unique way to cache resources (js/css) for plugin, and it need to be "with-cached-resources" (#12830)

All of that will lead to a breaking change in plugin API, which seemed unavoidable in all case at least for API declaration.


Related issues 4 (0 open4 closed)

Related to API Authorizations - User story #12203: Interface to manage ACL and user token for API authorizationReleasedFrançois ARMANDActions
Related to Rudder plugins - Bug #12835: Multiple plugin build errors in 4.3ReleasedFrançois ARMANDActions
Has duplicate API Authorizations - Bug #12828: Plugin API are not registered for ACLRejectedFrançois ARMANDActions
Has duplicate Rudder plugins - Bug #12830: Plugin can't use "with-cached-resources" for js/cssRejectedFrançois ARMANDActions
Actions #1

Updated by François ARMAND over 4 years ago

  • Assignee changed from François ARMAND to Vincent MEMBRÉ
  • Pull Request set to https://github.com/Normation/rudder/pull/1974
Actions #2

Updated by François ARMAND over 4 years ago

  • Subject changed from Rudder API for ACL is buggy to Rudder 4.3 missing important features for plugins, especially ACL one
  • Description updated (diff)
  • Assignee changed from Vincent MEMBRÉ to François ARMAND
Actions #3

Updated by François ARMAND over 4 years ago

  • Has duplicate Bug #12828: Plugin API are not registered for ACL added
Actions #4

Updated by François ARMAND over 4 years ago

  • Is duplicate of Bug #12830: Plugin can't use "with-cached-resources" for js/css added
Actions #5

Updated by François ARMAND over 4 years ago

  • Status changed from In progress to Rejected

CLosing (part of #12808)

Actions #6

Updated by François ARMAND over 4 years ago

  • Is duplicate of deleted (Bug #12830: Plugin can't use "with-cached-resources" for js/css)
Actions #7

Updated by François ARMAND over 4 years ago

  • Has duplicate Bug #12830: Plugin can't use "with-cached-resources" for js/css added
Actions #8

Updated by Vincent MEMBRÉ over 4 years ago

  • Parent task deleted (#12203)
Actions #9

Updated by Vincent MEMBRÉ over 4 years ago

  • Status changed from Rejected to New
  • Parent task set to #12203
Actions #10

Updated by François ARMAND over 4 years ago

  • Parent task deleted (#12203)
Actions #11

Updated by François ARMAND over 4 years ago

  • Status changed from New to In progress
Actions #12

Updated by François ARMAND over 4 years ago

  • Related to User story #12203: Interface to manage ACL and user token for API authorization added
Actions #13

Updated by François ARMAND over 4 years ago

  • Assignee changed from François ARMAND to Vincent MEMBRÉ
Actions #14

Updated by Rudder Quality Assistant over 4 years ago

  • Assignee changed from Vincent MEMBRÉ to François ARMAND
Actions #15

Updated by François ARMAND over 4 years ago

  • Status changed from In progress to Pending release

Applied in changeset commit:rudder|ba41803f1df407efe74aaf21f491843691a652e6.

Actions #16

Updated by Vincent MEMBRÉ over 4 years ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 4.3.3 which was released today.

Actions #17

Updated by Vincent MEMBRÉ over 4 years ago

  • Related to Bug #12835: Multiple plugin build errors in 4.3 added
Actions #18

Updated by Vincent MEMBRÉ over 4 years ago

  • Project changed from Rudder to API Authorizations
  • Category deleted (102)
  • Target version changed from 4.3.3 to 4.3-1.0
Actions

Also available in: Atom PDF