Project

General

Profile

Actions

Bug #12830

closed

Plugin can't use "with-cached-resources" for js/css

Added by François ARMAND almost 6 years ago. Updated almost 6 years ago.

Status:
Rejected
Priority:
N/A
Category:
-
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Name check:
Fix check:
Regression:

Description

Right now, plugins can't use the "with-cached-resources" directive that allows to versionned & cache plugin resources.

This is needed to avoid the case where the plugin changed css/js and the user updated it.

We also need to be more specific for plugin resources than just rudder version because the plugin can change its resources with its version.

So we propose to:

- update with-cached-resource to special case plugin resource rewrite
- we know we are dealing with a plugin resources because the url looks like "toserver/plugin-short-id".
- in that case, we also add plugin version with a pending "?plugin-version". That will allows to invalidate browser cache WITHOUT needing to modify the caching scheme on rudder side.

It may need a breaking in plugin management code so that we have a easy way to find back plugin information based on their id (so -> Rudder 4.3 only)


Related issues 1 (0 open1 closed)

Is duplicate of API authorizations - Bug #12808: Rudder 4.3 missing important features for plugins, especially ACL oneReleasedFrançois ARMANDActions
Actions #1

Updated by François ARMAND almost 6 years ago

  • Has duplicate Bug #12808: Rudder 4.3 missing important features for plugins, especially ACL one added
Actions #2

Updated by François ARMAND almost 6 years ago

  • Status changed from In progress to Rejected

CLosing (part of #12808)

Actions #3

Updated by François ARMAND almost 6 years ago

  • Has duplicate deleted (Bug #12808: Rudder 4.3 missing important features for plugins, especially ACL one)
Actions #4

Updated by François ARMAND almost 6 years ago

  • Is duplicate of Bug #12808: Rudder 4.3 missing important features for plugins, especially ACL one added
Actions #5

Updated by François ARMAND almost 6 years ago

  • Status changed from Rejected to New
Actions #6

Updated by François ARMAND almost 6 years ago

  • Status changed from New to Rejected
Actions #7

Updated by Vincent MEMBRÉ almost 6 years ago

  • Project changed from Rudder to Rudder plugins
  • Category deleted (Plugins integration)
  • Target version changed from 4.3.3 to 4.3
Actions

Also available in: Atom PDF