Project

General

Profile

Bug #12931

Agent installation on debian7 does not provide a ready to run agent

Added by Félix DALLIDET almost 2 years ago. Updated almost 2 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
-
Target version:
Pull Request:
Severity:
User visibility:
Effort required:
Priority:
0

Description

I try to install the rudder agent on a debian7 vm.
Install went fine, I did a run without Rudder server configured.
Configured a server in the '/var/rudder/cfengine-community/policy_server.dat'

Everything went fine until I tried to run an inventory and get the following error message:

Rudder agent 4.3.3~rc1~git201807102349-wheezy0
Node uuid: 83913412-996f-41bd-9b91-3499885d4211
/var/rudder/ncf/common/20_cfe_basics/dry_run_lib.cf:78:0: error: Duplicate definition of bundle set_dry_run_mode with type agent
/var/rudder/ncf/common/20_cfe_basics/dry_run_lib.unsupported.cf:32:0: error: Duplicate definition of bundle set_dry_run_mode with type agent

## Summary #####################################################################
Not all components were displayed because we are not in full compliance mode. Please run with -g to force full compliance mode.
Execution time: 0.46s
################################################################################

Running

NCF_CACHE_PATH=/var/rudder/cfengine-community/state /bin/sh /var/rudder/ncf/common/10_ncf_internals/list-compatible-inputs --capability-file /opt/rudder/etc/agent-capabilities --agent-version 3.10.4 --ncf-path '/var/rudder/ncf' common/20_cfe_basics

with set -x shows that I had conflicting cache in '/var/rudder/cfengine-community/state/ncf-exclude-cache-3.10.4' and the @agent_requirements of the dry-run bundle were not checked.

Removing the cache resolves the conflicting bundle. Inventory can be sent but with this error message

sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory
Rudder agent 4.3.3~rc1~git201807102349-wheezy0
Node uuid: 83913412-996f-41bd-9b91-3499885d4211
sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory

## Summary #####################################################################
Not all components were displayed because we are not in full compliance mode. Please run with -g to force full compliance mode.
Execution time: 0.19s
################################################################################

And agent can not be updated:sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory
 warning: Could not determine current directory (getcwd: No such file or directory)
 warning: Could not determine current directory (getcwd: No such file or directory)
R: *********************************************************************************
* rudder-agent could not get an updated configuration from the policy server.   *
* This can be caused by:                                                        *
*   * an agent key that has been changed                                        *
*   * if this node is not accepted or deleted node on the Rudder root server    *
*   * if this node has changed policy server without sending a new inventory    *
* Any existing configuration policy will continue to be applied without change. *
*********************************************************************************
ok: Rudder agent promises were updated.

Nor run:

sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory
Rudder agent 4.3.3~rc1~git201807102349-wheezy0
Node uuid: 83913412-996f-41bd-9b91-3499885d4211
sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory
error    Rudder agent was interrupted during execution by a fatal error
         Run with -i to see log messages.

## Summary #####################################################################
0 components verified in 1 directives
Execution time: 0.18s
################################################################################


Related issues

Is duplicate of Rudder - Bug #12698: rudder-agent 4.3 install hangs on Debian 7ReleasedBenoît PECCATTEActions
#1

Updated by Félix DALLIDET almost 2 years ago

The run in info log results in:

root@server:~# rudder agent run -i
Rudder agent 4.3.3~rc1~git201807102349-wheezy0
Node uuid: 83913412-996f-41bd-9b91-3499885d4211
   error: Can't stat file '/var/rudder/ncf/+ [ 7 -lt 3 ]' for parsing. (stat: No such file or directory)
   error: Policy failed validation with command '"/var/rudder/cfengine-community/bin/cf-promises" -c "/var/rudder/cfengine-community/inputs/promises.cf"'
   error: Error reading CFEngine policy. Exiting...
error    Rudder agent was interrupted during execution by a fatal error

## Summary #####################################################################
0 components verified in 1 directives
Execution time: 0.19s
################################################################################

note that the hostname is server but there is only the rudder-agent package installed from the rudder repos.

#2

Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 4.3.3 to 4.3.4
#3

Updated by Félix DALLIDET almost 2 years ago

I re-tried on a fresh VM, install and inventory went fine... I do not know how I ended up with the broken state describe up there.

#4

Updated by Alexis MOUSSET almost 2 years ago

  • Is duplicate of Bug #12698: rudder-agent 4.3 install hangs on Debian 7 added
#5

Updated by Alexis MOUSSET almost 2 years ago

  • Status changed from New to Rejected

Also available in: Atom PDF