Project

General

Profile

Bug #12967

rudder agent can't run on AIX: Undefined bundle _create_current_expected_reports_file

Added by François ARMAND almost 2 years ago. Updated almost 2 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Agent
Target version:
Pull Request:
Severity:
User visibility:
Effort required:
Priority:
0

Description

A fresh install of rudder agent 4.1 on AIX leads to:

root@sovma136:/# rudder agent run -i
Rudder agent 4.1.14.rc1.git201807152310 (CFEngine Core 3.10.4)
Node uuid: ffffffff-f4e8-0000-02c0-a8fd88000000
   error: Function 'readfile' failed to read file: /var/rudder/cfengine-community/policy_server.dat
   error: Function 'readfile' failed to read file: /var/rudder/cfengine-community/policy_server.dat
   error: Function 'readfile' failed to read file: /var/rudder/cfengine-community/policy_server.dat
   error: Function 'readfile' failed to read file: /var/rudder/cfengine-community/policy_server.dat
/var/rudder/cfengine-community/inputs/promises.cf:358:0: error: Undefined bundle _create_current_expected_reports_file with type usebundle
/var/rudder/cfengine-community/inputs/promises.cf:486:0: error: Undefined bundle _clean_old_expected_reports_file with type usebundle
   error: Policy failed validation with command '"/var/rudder/cfengine-community/bin/cf-promises" -c "/var/rudder/cfengine-community/inputs/promises.cf"'
   error: Error reading CFEngine policy. Exiting...

error    Rudder agent was interrupted during execution by a fatal error

## Summary #####################################################################
0 components verified in 1 directives
execution time: -1531737146.00s
################################################################################
You have mail in /usr/spool/mail/root

Related issues

Related to Rudder - Bug #12969: Uninstall rudder-agent does not clean /var/ruder/ncfNewActions
#1

Updated by François ARMAND almost 2 years ago

  • Status changed from New to Rejected

Actually, the problem was a bad content in /var/rudder/ncf, because I tried to install an agent in 4.3 before installaling it in 4.1.
So the problem is actually that "rpm -e rudder-agent" does not remove /var/rudder/ncf content.

I'm closing that one and opening an other, not grave, for the cleaning.

#2

Updated by François ARMAND almost 2 years ago

  • Related to Bug #12969: Uninstall rudder-agent does not clean /var/ruder/ncf added

Also available in: Atom PDF