Project

General

Profile

Architecture #13313

Update all rudder dependencies

Added by François ARMAND 4 months ago. Updated 3 months ago.

Status:
Released
Priority:
N/A
Category:
Architecture - Dependencies
Target version:
Effort required:
Tags:

Description

Rudder 5.0 is the next long term support version of Rudder. We really need to update all dependencies, and in particular scala/unboundid/lift/bouncy castle/spring to have a chance to support it for a couple of years - especially now that Java has a 6 months release cycle.


Subtasks

Architecture #13331: Update all rudder dependencies in scala-ldapReleasedVincent MEMBRÉ
Architecture #13332: Update all rudder dependencies in ldap-inventoryReleasedVincent MEMBRÉ
Architecture #13340: Used import removed in ldap-inventory breaks compilationReleasedVincent MEMBRÉ
Architecture #13343: IOUtils import also removed by error in RudderReleasedVincent MEMBRÉ
Architecture #13333: Update all rudder dependencies in rudderReleasedVincent MEMBRÉ
Architecture #13344: http4s must be updated to 0.18.16ReleasedVincent MEMBRÉ
Architecture #13380: NoSuchMethod error in datasource for a cat-effect methodReleasedVincent MEMBRÉ

Associated revisions

Revision dd77ad2a (diff)
Added by François ARMAND 4 months ago

Fixes #13313: Update all rudder dependencies

History

#1 Updated by François ARMAND 4 months ago

  • Status changed from New to In progress

#2 Updated by François ARMAND 4 months ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from François ARMAND to Vincent MEMBRÉ
  • Pull Request set to https://github.com/Normation/rudder-parent-pom/pull/54

#3 Updated by François ARMAND 4 months ago

  • Status changed from Pending technical review to Pending release

#4 Updated by Vincent MEMBRÉ 3 months ago

  • Status changed from Pending release to Released
This bug has been fixed in Rudder 5.0.0~beta2 which was released today.
Changelog

Also available in: Atom PDF