Project

General

Profile

Bug #13686

agent 13.04 fails to generate an inventory when curl is not installed

Added by Nicolas CHARLES almost 2 years ago. Updated almost 2 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Packaging
Target version:
Pull Request:
Severity:
User visibility:
Effort required:
Priority:
0

Description

when generating an inventory, i get the following error

rudder     info: Executing 'no timeout' ... '/opt/rudder/bin/rudder-perl /var/rudder/cfengine-community/inputs/common/utilities/minicurl --no-verify --get --file "/var/rudder/cfengine-community/rudder-server-uuid.txt" --url http://server/uuid'
   error: Finished command related to promiser '/opt/rudder/bin/rudder-perl /var/rudder/cfengine-community/inputs/common/utilities/minicurl --no-verify --get --file "/var/rudder/cfengine-community/rudder-server-uuid.txt" --url http://server/uuid' -- an error occurred, returned 2
  notice: Q: "...udder-perl /var": Can't locate LWP/UserAgent.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.14.2 /usr/local/share/perl/5.14.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.14 /usr/share/perl/5.14 /usr/local/lib/site_perl .) at /var/rudder/cfengine-community/inputs/common/utilities/minicurl line 29.
Q: "...udder-perl /var": BEGIN failed--compilation aborted at /var/rudder/cfengine-community/inputs/common/utilities/minicurl line 29.
rudder     info: Last 2 quoted lines were generated by promiser '/opt/rudder/bin/rudder-perl /var/rudder/cfengine-community/inputs/common/utilities/minicurl --no-verify --get --file "/var/rudder/cfengine-community/rudder-server-uuid.txt" --url http://server/uuid'
rudder     info: Completed execution of '/opt/rudder/bin/rudder-perl /var/rudder/cfengine-community/inputs/common/utilities/minicurl --no-verify --get --file "/var/rudder/cfengine-community/rudder-server-uuid.txt" --url http://server/uuid'


Related issues

Is duplicate of Rudder - Bug #13687: Use embedded curl when availableReleasedAlexis MOUSSETActions
#1

Updated by Nicolas CHARLES almost 2 years ago

  • Project changed from ncf to Rudder
  • Category changed from Packaging to Packaging
#2

Updated by Nicolas CHARLES almost 2 years ago

  • Subject changed from agent 13.04 fails to generate an inventory to agent 13.04 fails to generate an inventory when curl is not installed

Ha, curl is not installed on the system automatically

#3

Updated by Nicolas CHARLES almost 2 years ago

  • Related to Bug #13687: Use embedded curl when available added
#4

Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 5.0.2 to 5.0.3
#5

Updated by François ARMAND almost 2 years ago

Duplicates #13687

#6

Updated by François ARMAND almost 2 years ago

  • Status changed from New to Rejected
#7

Updated by François ARMAND almost 2 years ago

  • Related to deleted (Bug #13687: Use embedded curl when available)
#8

Updated by François ARMAND almost 2 years ago

  • Is duplicate of Bug #13687: Use embedded curl when available added

Also available in: Atom PDF