Project

General

Profile

Bug #13891

Improve error messsage when path to install a plugin package is not correct

Added by Nicolas CHARLES over 1 year ago. Updated over 1 year ago.

Status:
Released
Priority:
N/A
Category:
Plugins integration
Target version:
Severity:
User visibility:
Effort required:
Priority:
0

Description

I made a typo when I tried to install a rpkg, so the file was not found
As a result I had as an output:


/opt/rudder/bin/rudder-pkg install-file /vagrant/rudder-plugin/rudder-plugin-scale-out-relay-5.0-1.2-SNAPSHOT.rpkg 
Installing /vagrant/rudder-plugin/rudder-plugin-scale-out-relay-5.0-1.2-SNAPSHOT.rpkg
ar: /vagrant/rudder-plugin/rudder-plugin-scale-out-relay-5.0-1.2-SNAPSHOT.rpkg: No error

it took me a very long time to find that the file was indeed not existing

Also available in: Atom PDF