Project

General

Profile

Actions

Bug #13892

closed

Once added, we don't know if a node property is json or string

Added by François ARMAND over 3 years ago. Updated about 3 years ago.

Status:
Rejected
Priority:
N/A
Category:
Web - Nodes & inventories
Target version:
Severity:
Minor - inconvenience | misleading | easy workaround
UX impact:
User visibility:
Getting started - demo | first install | Technique editor and level 1 Techniques
Effort required:
Small
Priority:
62

Description

When we are adding a node property, it's easy to check that the parameter is json or string. There is a validator for that.

But once added, we don't know anymore. And since we are not able to edit a parameter (arg), we can't know ever if Rudder think it's a string or json.

We need to:

- know in the backend what it is,
- display a capsule [json] or [string] depending on that information.


Related issues 2 (0 open2 closed)

Related to Rudder - Bug #12360: It's difficult to know if the node property added is valid json ReleasedVincent MEMBRÉActions
Is duplicate of Rudder - User story #14593: Add a "Copy to clipboard" button for Node properties and show its typeReleasedVincent MEMBRÉActions
Actions #1

Updated by François ARMAND over 3 years ago

  • Related to Bug #12360: It's difficult to know if the node property added is valid json added
Actions #2

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 4.1.17 to 4.1.18
Actions #3

Updated by Benoît PECCATTE over 3 years ago

  • Effort required set to Small
  • Priority changed from 50 to 66
Actions #4

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 4.1.18 to 4.1.19
  • Priority changed from 66 to 65
Actions #5

Updated by François ARMAND over 3 years ago

  • Assignee set to François ARMAND
Actions #6

Updated by Alexis Mousset over 3 years ago

  • Target version changed from 4.1.19 to 4.1.20
Actions #7

Updated by François ARMAND over 3 years ago

  • Target version changed from 4.1.20 to 4.1.21
  • Priority changed from 65 to 64
Actions #8

Updated by François ARMAND about 3 years ago

  • Is duplicate of User story #14593: Add a "Copy to clipboard" button for Node properties and show its type added
Actions #9

Updated by François ARMAND about 3 years ago

  • Status changed from New to Rejected
  • Priority changed from 64 to 62

I'm closing that one as it was superseeded by #14593

Actions

Also available in: Atom PDF