Project

General

Profile

Actions

Bug #13906

closed

rudder-agent 4.3.6 does not install correctly from Debian 9.6 Installer

Added by Oliver Brandmueller over 5 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Agent
Target version:
Severity:
Minor - inconvenience | misleading | easy workaround
UX impact:
User visibility:
Operational - other Techniques | Rudder settings | Plugins
Effort required:
Medium
Priority:
13
Name check:
Fix check:
Regression:

Description

When installing rudder-agent 4.3.6 (did not try 5.x) from Debian Installer (Debian 9.6) the installed rudder agent does not run correctly; it is on the system, you can do rudder agent (run|health|check|inventory) manually but get various warnings about the executor not running or the service being disabled in systemd.
I'm installing rudder-agent from d-i by adding the repository via

d-i apt-setup/local0/repository [...]

and the key from a local (tftp) source. Then a

d-i pkgsel/include string rudder-agent

is done, finally there's a

d-i preseed/late_command string echo [...] > /target/var/rudder/cfengine-community/policy_server.dat

It used to work with Debian 9.5 / rudder-agent 4.3.4 and the setup of the policy server as well as the rudder component seems to be OK; I haven't checked deeper, but I suspect problems with cf-execd or cf-agent to be causing the misbehaviour. The cron command to run rudder agent check every 5min is correctly set up, though.

The workaround is to install rudder-agent manually after installing Debian (which is a bit of a hassle for an automated deployment, though)

Actions #1

Updated by Benoît PECCATTE over 5 years ago

d-i preseed/late_command string echo [...] > /target/var/rudder/cfengine-community/policy_server.dat

This should not be needed, there is a debconf entry to configure the policy server : rudder-agent/policy-server

Is the file still there after the install ?

Actions #2

Updated by Oliver Brandmueller over 5 years ago

Benoît PECCATTE wrote:

Is the file still there after the install ?

The file is there after install; I didn't know about the debconf entry. However, the problem ist, that all services (rudder-agent, rudder-cf-execd, rudder-cf-serverd) are instaled, but remain disabled. I meanwhile do an explicit in-target systemctl enable [...] for each of those services, then everythin works as expected. This is only needed during automated install on d-i, when installaing manually in a freshly set up system the services are enabled by default.

Actions #3

Updated by François ARMAND about 5 years ago

  • Target version set to 4.3.12
  • User visibility set to Operational - other Techniques | Rudder settings | Plugins
  • Priority changed from 0 to 31
Actions #4

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.3.12 to 4.3.13
  • Priority changed from 31 to 30
Actions #5

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.3.13 to 4.3.14
Actions #6

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 4.3.14 to 587
  • Priority changed from 30 to 29
Actions #7

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 587 to 4.3.14
Actions #8

Updated by Alexis Mousset almost 5 years ago

  • Target version changed from 4.3.14 to 5.0.13

Probably still exists in 5.0

Actions #9

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 5.0.13 to 5.0.14
  • Priority changed from 29 to 28
Actions #10

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.14 to 5.0.15
Actions #11

Updated by Benoît PECCATTE over 4 years ago

  • Effort required set to Medium
  • Priority changed from 28 to 13

Needs reproduction

Actions #12

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.15 to 5.0.16
Actions #13

Updated by Alexis Mousset over 4 years ago

  • Target version changed from 5.0.16 to 5.0.17
Actions #14

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 5.0.17 to 5.0.18
Actions #15

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.18 to 5.0.19
Actions #16

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.19 to 5.0.20
Actions #17

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 5.0.20 to 797
Actions #18

Updated by Benoît PECCATTE almost 3 years ago

  • Target version changed from 797 to 6.1.14
Actions #19

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #20

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #21

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #22

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #23

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #24

Updated by Alexis Mousset over 2 years ago

  • Status changed from New to Rejected

4.3 is not supported anymore.

Actions

Also available in: Atom PDF