Project

General

Profile

Actions

Bug #13941

closed

Bad LDAP credential after upgrading to 5.0

Added by Nicolas CHARLES over 5 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Packaging
Target version:
Severity:
Major - prevents use of part of Rudder | no simple workaround
UX impact:
User visibility:
Operational - other Techniques | Rudder settings | Plugins
Effort required:
Small
Priority:
57
Name check:
Fix check:
Regression:

Description

(was: Broken Rudder after upgrading from 4.2 to 5.0)

A case happened when a user upgraded from 4.2.6 to 5.0.2, and resulted in a broken Rudder:
  • web interface didn't start, due to invalid ldap credentials
  • agent couldn't fix the credentials, as policies are out of sync with ncf

to make matter worse, a bug in the cron edition resulted in a non-run rudder agent check

we should have something, in postinst, to ensure password are correct, even without a working agent

Actions #1

Updated by Nicolas CHARLES over 5 years ago

issue was indeed the password in slapd.conf which was reverted to default password

Actions #2

Updated by Nicolas CHARLES over 5 years ago

rudder agent reset cannot fix the issue, as reset doesn't reset on root

Actions #3

Updated by Nicolas CHARLES over 5 years ago

we could, at postinst:
  1. check that web interface run, if not
  2. check that policy are correct, if not, run rudder agent reset --force (or whatever option there is)
  3. run rudder agent run
Actions #4

Updated by Benoît PECCATTE over 5 years ago

  • Subject changed from Broken Rudder after upgrading from 4.2 to 5.0, to Bad LDAP credential after upgrading to 5.0
  • Description updated (diff)
  • Severity set to Major - prevents use of part of Rudder | no simple workaround
  • User visibility set to Operational - other Techniques | Rudder settings | Plugins
  • Priority changed from 0 to 52
Actions #5

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.3.8 to 4.3.9
  • Priority changed from 52 to 51
Actions #6

Updated by Alexis Mousset over 5 years ago

  • Target version changed from 4.3.9 to 4.3.10
Actions #7

Updated by François ARMAND over 5 years ago

  • Target version changed from 4.3.10 to 4.3.11
  • Priority changed from 51 to 50
Actions #8

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.3.11 to 4.3.12
  • Priority changed from 50 to 49
Actions #9

Updated by Benoît PECCATTE about 5 years ago

  • Target version changed from 4.3.12 to 5.0.10
  • Priority changed from 49 to 48
Actions #10

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 5.0.10 to 5.0.11
Actions #11

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 5.0.11 to 5.0.12
Actions #12

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 5.0.12 to 5.0.13
  • Priority changed from 48 to 47
Actions #13

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 5.0.13 to 5.0.14
  • Priority changed from 47 to 45
Actions #14

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.14 to 5.0.15
  • Priority changed from 45 to 44
Actions #15

Updated by Benoît PECCATTE over 4 years ago

  • Effort required set to Small
  • Priority changed from 44 to 57
Actions #16

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.15 to 5.0.16
  • Priority changed from 57 to 56
Actions #17

Updated by Alexis Mousset over 4 years ago

  • Target version changed from 5.0.16 to 5.0.17
Actions #18

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 5.0.17 to 5.0.18
Actions #19

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.18 to 5.0.19
Actions #20

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.19 to 5.0.20
Actions #21

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 5.0.20 to 797
Actions #22

Updated by Benoît PECCATTE almost 3 years ago

  • Target version changed from 797 to 6.1.14
Actions #23

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #24

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #25

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #26

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #27

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #28

Updated by François ARMAND over 2 years ago

  • Status changed from New to Rejected
  • Priority changed from 56 to 57

A lot of packaging logic changed since then, and we corrected these perm problem. I'm closing it.

Actions

Also available in: Atom PDF