Project

General

Profile

Actions

Bug #14132

closed

"classes promises do not support promise locking" warning message when running the agent

Added by Benoît PECCATTE over 2 years ago. Updated over 2 years ago.

Status:
Released
Priority:
N/A
Category:
System techniques
Target version:
Severity:
User visibility:
Effort required:
Priority:
0

Description

centos7_relay: warning: ifelapsed attribute specified in action body for classes promise 'should_disable_agent', but classes promises do not support promise locking

There is an immediate in promise.st line 211 when defining should_disable_agent


Related issues

Has duplicate Rudder - Question #14256: error on agent runResolvedActions
Actions #1

Updated by Alexis MOUSSET over 2 years ago

  • Target version set to 4.3.9

The problem is displayed since CFEngine 3.12 (Rudder 5.0).

Actions #2

Updated by Alexis MOUSSET over 2 years ago

  • Status changed from New to In progress
Actions #3

Updated by Alexis MOUSSET over 2 years ago

  • Subject changed from cfengine error chen agent is disabled to cfengine error when agent is disabled
  • Status changed from In progress to New
Actions #4

Updated by Alexis MOUSSET over 2 years ago

  • Status changed from New to Pending technical review
  • Assignee changed from Alexis MOUSSET to Nicolas CHARLES
  • Pull Request set to https://github.com/Normation/rudder-techniques/pull/1402
Actions #5

Updated by Anonymous over 2 years ago

  • Status changed from Pending technical review to Pending release
Actions #6

Updated by Alexis MOUSSET over 2 years ago

  • Subject changed from cfengine error when agent is disabled to "classes promises do not support promise locking" warning message when running the agent
Actions #7

Updated by Alexis MOUSSET over 2 years ago

  • Status changed from Pending release to Released
This bug has been fixed in Rudder 4.3.9 and 5.0.5 which were released today.
Changelog
Changelog
Actions #8

Updated by Alexis MOUSSET over 2 years ago

Actions

Also available in: Atom PDF