Project

General

Profile

Actions

Bug #14184

closed

Enhance bug message when creating a technique with the same name as an existing GM

Added by Félix DALLIDET over 5 years ago. Updated 8 months ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Web - Technique editor
Severity:
Minor - inconvenience | misleading | easy workaround
UX impact:
User visibility:
Getting started - demo | first install | Technique editor and level 1 Techniques
Effort required:
Very Small
Priority:
0
Name check:
Fix check:
Regression:
No

Description

I tried to add a technique with the name "user home", which was interpreted in cfengine as "user_home" which is the name of an already existing GM.
The message was not that much explicit and I think it should explicitly tell that the technique name is already in use in Rudder.

An Error occured! Could not write technique 'user_home' from path /var/rudder/configuration-repository/ncf, cause is: Error while running post-hook command /var/rudder/configuration-repository/ncf/ncf-hooks.d/post.write_technique.50_rudderify.sh /var/rudder/configuration-repository/ncf user_home
Details:

INFO: Alternative source path added: /var/rudder/configuration-repository/ncf
ERROR: Could not parse Technique 'user_home'
 caused by : Error while running post-hook command cf-promises -pjson -f /var/rudder/configuration-repository/ncf/50_techniques/user_home/user_home.cf
/var/rudder/configuration-repository/ncf/50_techniques/user_home/user_home.cf:9:0: error: Conflicting arity in calling bundle user_home, expected 0 arguments, 2 given

Error: Unable to create Rudder Technique files related to ncf Technique user_home, cannot find ncf Technique user_home
None


Related issues 1 (0 open1 closed)

Related to Rudder - Bug #12869: If we call a technique with same name as a generic method, policy generation fails because of a duplicate bundle nameRejectedActions
Actions #1

Updated by Alexis Mousset over 5 years ago

  • Target version changed from 4.1.19 to 4.1.20
Actions #2

Updated by François ARMAND over 5 years ago

  • Target version changed from 4.1.20 to 4.1.21
Actions #3

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.1.21 to 4.1.22
Actions #4

Updated by Benoît PECCATTE about 5 years ago

  • Target version changed from 4.1.22 to 5.0.10
Actions #5

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 5.0.10 to 5.0.11
Actions #6

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 5.0.11 to 5.0.12
Actions #7

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 5.0.12 to 5.0.13
Actions #8

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 5.0.13 to 5.0.14
Actions #9

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.14 to 5.0.15
Actions #10

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.15 to 5.0.16
Actions #11

Updated by Alexis Mousset over 4 years ago

  • Target version changed from 5.0.16 to 5.0.17
Actions #12

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 5.0.17 to 5.0.18
Actions #13

Updated by Benoît PECCATTE about 4 years ago

  • Target version changed from 5.0.18 to 6.2.0~beta1
Actions #14

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.2.0~beta1 to 6.2.0~rc1
Actions #15

Updated by François ARMAND over 3 years ago

  • Tracker changed from User story to Bug
  • Project changed from 41 to Rudder
  • Category changed from Technique editor - Techniques to Web - Technique editor
  • Target version changed from 6.2.0~rc1 to 6.1.7
  • User visibility set to Getting started - demo | first install | Technique editor and level 1 Techniques
  • Severity set to Minor - inconvenience | misleading | easy workaround
  • Priority set to 42
Actions #16

Updated by François ARMAND over 3 years ago

  • Effort required set to Very Small
  • Priority changed from 42 to 66
Actions #17

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.7 to 6.1.8
Actions #18

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.8 to 6.1.9
Actions #19

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.9 to 6.1.10
Actions #20

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.10 to 6.1.11
Actions #21

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.11 to 6.1.12
Actions #22

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.12 to 6.1.13
Actions #23

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.13 to 6.1.14
Actions #24

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #25

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #26

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #27

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #28

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #29

Updated by François ARMAND over 2 years ago

  • Related to Bug #12869: If we call a technique with same name as a generic method, policy generation fails because of a duplicate bundle name added
Actions #30

Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 6.1.19 to 6.1.20
  • Priority changed from 66 to 68
Actions #31

Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 6.1.20 to 6.1.21
  • Priority changed from 68 to 69
Actions #32

Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 6.1.21 to old 6.1 issues to relocate
Actions #33

Updated by Elaad FURREEDAN 8 months ago

  • Status changed from New to Rejected
  • Priority changed from 69 to 0
  • Regression set to No

This is not longer the case, now if you named the technique "user home" it will transform the ID to "user_home_technique"

Actions

Also available in: Atom PDF