Project

General

Profile

Actions

Bug #14558

closed

Errors and warnings while upgrading from 4.3 to 5.0 on centos7

Added by Nicolas CHARLES about 5 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Packaging
Target version:
Severity:
Major - prevents use of part of Rudder | no simple workaround
UX impact:
User visibility:
Operational - other Techniques | Rudder settings | Plugins
Effort required:
Priority:
43
Name check:
Fix check:
Regression:

Description

Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Stopping Jetty: OK
  Mise à jour  : 1398866025:rudder-jetty-5.0.9.rc1.git201903311004-1.EL.7.noarch                                                                                                                                                         1/22 
  Mise à jour  : 1398866025:ncf-5.0.9.rc1.git201903311004-1.EL.7.noarch                                                                                                                                                                  2/22 
  Mise à jour  : 1398866025:rudder-inventory-ldap-5.0.9.rc1.git201903311004-1.EL.7.x86_64                                                                                                                                                3/22 
INFO: Setting rudder-slapd as a boot service...rudder-slapd.service is not a native service, redirecting to /sbin/chkconfig.
Executing /sbin/chkconfig rudder-slapd on
 Done
INFO: Restarting rudder-slapd...Job for rudder-slapd.service failed because the control process exited with error code. See "systemctl status rudder-slapd.service" and "journalctl -xe" for details.
 Done
  Mise à jour  : 1398866025:rudder-agent-5.0.9.rc1.git201903311004-1.EL.7.x86_64                                                                                                                                                         4/22 
Warning: rudder-agent.service changed on disk. Run 'systemctl daemon-reload' to reload units.
ok: stop service rudder-agent succeeded
ok: Rudder agent is now disabled.
INFO: Ensuring correct permissions on the keys directory... Done.
ok: Rudder agent has been enabled but not started, wait for next cron run.
Warning: rudder-agent.service changed on disk. Run 'systemctl daemon-reload' to reload units.
ok: start service rudder-agent succeeded

# systemctl status rudder-slapd.service
● rudder-slapd.service - LSB: OpenLDAP
   Loaded: loaded (/etc/rc.d/init.d/rudder-slapd; bad; vendor preset: disabled)
   Active: failed (Result: exit-code) since lun. 2019-04-01 13:51:49 UTC; 3min 26s ago
     Docs: man:systemd-sysv-generator(8)

avril 01 13:51:47 server rudder-slapd[5729]: rudder-slapd: [INFO] Launching OpenLDAP replication...
avril 01 13:51:47 server rudder-slapd[5729]: rudder-slapd: [INFO] no replica found in configuration, aborting lauching slurpd
avril 01 13:51:47 server rudder-slapd[5729]: rudder-slapd: [INFO] no db_recover done
avril 01 13:51:47 server rudder-slapd[5729]: rudder-slapd: [INFO] Launching OpenLDAP...
avril 01 13:51:47 server rudder-slapd[5729]: rudder-slapd: [OK] file descriptor limit set to 1024
avril 01 13:51:49 server rudder-slapd[5729]: rudder-slapd[5772]: [ALERT] no PID file for rudder-slapd
avril 01 13:51:49 server systemd[1]: rudder-slapd.service: control process exited, code=exited status=1
avril 01 13:51:49 server systemd[1]: Failed to start LSB: OpenLDAP.
avril 01 13:51:49 server systemd[1]: Unit rudder-slapd.service entered failed state.
avril 01 13:51:49 server systemd[1]: rudder-slapd.service failed.

Related issues 2 (0 open2 closed)

Related to Rudder - Bug #14553: systemctl stop rudder-slapd does not actually stop rudder's slapdResolvedActions
Related to Rudder - Bug #14565: rudder-slapd/rudder-jetty pid file is not present in Rudder 5 preventing restart of service and causing error at upgradeRejectedActions
Actions #1

Updated by François ARMAND about 5 years ago

It may be related to #14553

Actions #2

Updated by François ARMAND about 5 years ago

  • Related to Bug #14553: systemctl stop rudder-slapd does not actually stop rudder's slapd added
Actions #3

Updated by Nicolas CHARLES about 5 years ago

rudder-slapd was indeed not restarted

root      1352  0.0  1.6 105267644 24620 ?     Ssl  13:38   0:00 /opt/rudder/libexec/slapd -h ldap://localhost:389 -n rudder-slapd -f /opt/rudder/etc/openldap/slapd.conf

Actions #4

Updated by Nicolas CHARLES about 5 years ago

  • Related to Bug #14565: rudder-slapd/rudder-jetty pid file is not present in Rudder 5 preventing restart of service and causing error at upgrade added
Actions #5

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 5.0.9 to 5.0.10
Actions #6

Updated by François ARMAND about 5 years ago

  • Subject changed from errors and warnig while upgrading from 4.3 to 5.0 on centos7 to Errors and warnings while upgrading from 4.3 to 5.0 on centos7
  • Severity set to Major - prevents use of part of Rudder | no simple workaround
  • User visibility set to Operational - other Techniques | Rudder settings | Plugins
  • Priority changed from 0 to 51

Major because sometimes it means that the upgrade can partially fail.

Actions #7

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 5.0.10 to 5.0.11
Actions #8

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 5.0.11 to 5.0.12
Actions #9

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 5.0.12 to 5.0.13
  • Priority changed from 51 to 50
Actions #10

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 5.0.13 to 5.0.14
  • Priority changed from 50 to 49
Actions #11

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.14 to 5.0.15
  • Priority changed from 49 to 48
Actions #12

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.15 to 5.0.16
  • Priority changed from 48 to 46
Actions #13

Updated by Alexis Mousset over 4 years ago

  • Target version changed from 5.0.16 to 5.0.17
  • Priority changed from 46 to 44
Actions #14

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 5.0.17 to 5.0.18
  • Priority changed from 44 to 43
Actions #15

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.18 to 5.0.19
Actions #16

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.19 to 5.0.20
Actions #17

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 5.0.20 to 797
Actions #18

Updated by Benoît PECCATTE almost 3 years ago

  • Target version changed from 797 to 6.1.14
Actions #19

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #20

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #21

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #22

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #23

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #24

Updated by Alexis Mousset over 2 years ago

  • Status changed from New to Rejected

4.3 and 5.0 are not maintained anymore.

Actions

Also available in: Atom PDF