Project

General

Profile

Bug #15952

Rudder package does not work when there are no plugin compatible with the current version of Rudder

Added by Félix DALLIDET 9 months ago. Updated 8 months ago.

Status:
Released
Priority:
N/A
Category:
Plugins integration
Target version:
Severity:
User visibility:
Effort required:
Priority:
0

Description

It displays a python error:

Traceback (most recent call last):
  File "/opt/rudder/share/python/rudder-pkg/plugin.py", line 77, in getLatestCompatibleRelease
    return max(self.getCompatibleRelease())

It should not be displayed like that, also, we should mask the gpg outputs when updating the repo index.

#1

Updated by Félix DALLIDET 9 months ago

  • Status changed from New to In progress
  • Assignee set to Félix DALLIDET
#2

Updated by Félix DALLIDET 9 months ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Félix DALLIDET to Alexis MOUSSET
  • Pull Request set to https://github.com/Normation/rudder/pull/2527
#3

Updated by Vincent MEMBRÉ 9 months ago

  • Target version changed from 6.0.0~beta1 to 6.0.0
#4

Updated by François ARMAND 9 months ago

  • Target version changed from 6.0.0 to 6.0.0~beta1
#5

Updated by Félix DALLIDET 9 months ago

  • Status changed from Pending technical review to Pending release
#6

Updated by Vincent MEMBRÉ 8 months ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 6.0.0~beta1 which was released today.

Also available in: Atom PDF