Project

General

Profile

Actions

Bug #16050

closed

Remote-run hangs if sub-relay is not available

Added by Alexis Mousset over 4 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
N/A
Category:
Relay server or API
Target version:
Severity:
Minor - inconvenience | misleading | easy workaround
UX impact:
User visibility:
Infrequent - complex configurations | third party integrations
Effort required:
Priority:
18
Name check:
To do
Fix check:
To do
Regression:

Description

We should terminate the forwarding stream when we can't connect.

Actions #1

Updated by Alexis Mousset over 4 years ago

  • Target version changed from 6.0.0 to 6.0.1
Actions #2

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 6.0.1 to 6.0.2
Actions #3

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 6.0.2 to 6.0.3
Actions #4

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 6.0.3 to 6.0.4
Actions #5

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 6.0.4 to 6.0.5
Actions #6

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 6.0.5 to 6.0.6
Actions #7

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 6.0.6 to 6.0.7
Actions #8

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 6.0.7 to 6.0.8
Actions #9

Updated by François ARMAND almost 4 years ago

  • Severity set to Minor - inconvenience | misleading | easy workaround
  • User visibility set to Infrequent - complex configurations | third party integrations
  • Priority changed from 0 to 19

Infrequent because it needs two relay with the second one not responding.

Actions #10

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 6.0.8 to 6.0.9
Actions #11

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.0.9 to 6.0.10
  • Priority changed from 19 to 18
Actions #12

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.0.10 to 798
Actions #13

Updated by Benoît PECCATTE almost 3 years ago

  • Target version changed from 798 to 6.1.14
Actions #14

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #15

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #16

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #17

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #18

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #19

Updated by Alexis Mousset over 2 years ago

  • Assignee set to Alexis Mousset

I'll check in 7.0, not so infrequent as the root server is a relay itself.

Actions #20

Updated by Alexis Mousset over 2 years ago

  • Status changed from New to Resolved

Fixed in 7.0, and no easy way to fix it in 6.X.

Jan 25 13:41:58 server rudder-relayd[20078]: ERROR rudder_relayd::api::remote_run: forward error: HTTP status server error (503 Service Unavailable) for url (https://relay.rudder.local/rudder/relay-api/remote-r>
Jan 25 13:41:58 server rudder-relayd[20078]:  INFO relayd::api: 127.0.0.1:33894 "POST /rudder/relay-api/1/remote-run/nodes/e679d4ba-dd60-42ff-bd6f-4d81441d6a7a HTTP/1.1" 200 "-" "curl/7.61.1" 17.249154ms

closing.

Actions

Also available in: Atom PDF