Project

General

Profile

Actions

User story #16743

closed

Promote a node to relay

Added by Elaad FURREEDAN over 4 years ago. Updated almost 4 years ago.

Status:
Released
Priority:
N/A
Target version:
UX impact:
Suggestion strength:
User visibility:
Effort required:
Name check:
To do
Fix check:
To do
Regression:

Description

In the plugin we wants to be able to promote a node to relay via a REST API and UI.


Subtasks 2 (0 open2 closed)

Bug #13658: There are no eventlogs when converting a node to relayReleasedVincent MEMBRÉActions
User story #17177: Distribute node-to-relay script with the plugin ReleasedBenoît PECCATTEActions

Related issues 6 (0 open6 closed)

Related to Rudder - Architecture #16906: Be able to save in LDAP a Policy Server TargetReleasedFrançois ARMANDActions
Related to Rudder - Architecture #17112: Missing LDAP write operations to promote a node to relayReleasedVincent MEMBRÉActions
Related to Rudder - User story #17162: Add promote to relay endpoint in API documentationReleasedAlexis MoussetActions
Related to Rudder - Architecture #17132: Remove rudder-node-to-relay script from RudderRejectedAlexis MoussetActions
Related to Rudder - Architecture #17217: Replace node-to-relay script from rudder-packageReleasedAlexis MoussetActions
Is duplicate of Rudder - User story #7415: Promote Nodes to relay via Rest API or web uiRejectedVincent MEMBRÉActions
Actions #1

Updated by Elaad FURREEDAN over 4 years ago

  • Is duplicate of User story #7415: Promote Nodes to relay via Rest API or web ui added
Actions #2

Updated by Elaad FURREEDAN over 4 years ago

  • Target version set to 6.1-1.4
Actions #3

Updated by Elaad FURREEDAN over 4 years ago

  • Status changed from New to In progress
Actions #6

Updated by Elaad FURREEDAN over 4 years ago

Actions #13

Updated by Elaad FURREEDAN over 4 years ago

  • Assignee changed from Elaad FURREEDAN to Vincent MEMBRÉ
  • Pull Request set to https://github.com/Normation/rudder-plugins/pull/248
Actions #14

Updated by Elaad FURREEDAN about 4 years ago

  • Related to Bug #13658: There are no eventlogs when converting a node to relay added
Actions #15

Updated by Elaad FURREEDAN about 4 years ago

  • Related to Architecture #17112: Missing LDAP write operations to promote a node to relay added
Actions #16

Updated by Elaad FURREEDAN about 4 years ago

  • Related to User story #17162: Add promote to relay endpoint in API documentation added
Actions #17

Updated by Elaad FURREEDAN about 4 years ago

Actions #18

Updated by François ARMAND about 4 years ago

  • Status changed from In progress to Rejected

Duplicated

Actions #19

Updated by Elaad FURREEDAN about 4 years ago

Actions #20

Updated by Elaad FURREEDAN about 4 years ago

  • Related to User story #17177: Distribute node-to-relay script with the plugin added
Actions #21

Updated by Vincent MEMBRÉ about 4 years ago

  • Status changed from Rejected to Pending technical review
Actions #22

Updated by Vincent MEMBRÉ about 4 years ago

  • Related to deleted (Bug #13658: There are no eventlogs when converting a node to relay)
Actions #23

Updated by Anonymous about 4 years ago

  • Status changed from Pending technical review to Pending release
Actions #24

Updated by Anonymous about 4 years ago

Actions #25

Updated by Anonymous about 4 years ago

Actions #26

Updated by Vincent MEMBRÉ about 4 years ago

This bug has been fixed in Rudder 6.1-1.4 which was released today.

Actions #27

Updated by Vincent MEMBRÉ almost 4 years ago

  • Status changed from Pending release to Released
Actions

Also available in: Atom PDF