Project

General

Profile

Actions

Bug #16837

closed

userManagement produces missing reports when used in "check only" mode

Added by Félix DALLIDET almost 3 years ago. Updated 2 months ago.

Status:
Rejected
Priority:
N/A
Category:
Techniques
Target version:
Severity:
Major - prevents use of part of Rudder | no simple workaround
UX impact:
User visibility:
Getting started - demo | first install | Technique editor and level 1 Techniques
Effort required:
Priority:
0
Regression:
No

Description

When setting the "Policy to apply on this account" to "Check Only" and setting the shell on an already existing user with the wrong shell,
it does not report.

Still, I believe we should not fix it. This option is very old and most likely come from a time where the audit mode wasn't available.


Subtasks 1 (0 open1 closed)

Bug #18294: userManagement in audit mode with wrong shell lead to "abort run"ReleasedAlexis MoussetActions
Actions #1

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.0.4 to 6.0.5
Actions #2

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.0.5 to 6.0.6
Actions #3

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.0.6 to 6.0.7
Actions #4

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.0.7 to 6.0.8
Actions #5

Updated by François ARMAND over 2 years ago

  • Severity set to Major - prevents use of part of Rudder | no simple workaround
  • User visibility set to Getting started - demo | first install | Technique editor and level 1 Techniques
  • Priority changed from 0 to 66
Actions #6

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.0.8 to 6.0.9
  • Priority changed from 66 to 65
Actions #7

Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 6.0.9 to 6.0.10
  • Priority changed from 65 to 64
Actions #8

Updated by Nicolas CHARLES about 2 years ago

  • Status changed from New to In progress
  • Assignee set to Nicolas CHARLES
Actions #9

Updated by Nicolas CHARLES about 2 years ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Nicolas CHARLES to Félix DALLIDET
  • Pull Request set to https://github.com/Normation/rudder-techniques/pull/1620
Actions #10

Updated by Nicolas CHARLES about 2 years ago

  • Status changed from Pending technical review to Pending release
Actions #11

Updated by Alexis Mousset about 2 years ago

  • Subject changed from userManagement produce missing reports when used in Check only mode to userManagement produces missing reports when used in "check only" mode
  • Priority changed from 64 to 63
Actions #13

Updated by François ARMAND about 2 years ago

The correction seems to have worsen the problem: no I get "change detected in audit mode, abort"
=> see #18294

Actions #14

Updated by Vincent MEMBRÉ about 2 years ago

  • Status changed from Pending release to New

reverting the issue

Actions #15

Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 6.0.10 to 798
  • Priority changed from 63 to 62
Actions #16

Updated by Benoît PECCATTE over 1 year ago

  • Target version changed from 798 to 6.1.14
  • Priority changed from 62 to 58
Actions #17

Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #18

Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #19

Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #20

Updated by Vincent MEMBRÉ about 1 year ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #21

Updated by Vincent MEMBRÉ 12 months ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #22

Updated by Vincent MEMBRÉ 8 months ago

  • Target version changed from 6.1.19 to 6.1.20
Actions #23

Updated by Vincent MEMBRÉ 6 months ago

  • Target version changed from 6.1.20 to 6.1.21
Actions #24

Updated by Vincent MEMBRÉ 6 months ago

  • Target version changed from 6.1.21 to 6.1.22
Actions #25

Updated by Félix DALLIDET 2 months ago

  • Status changed from New to Rejected
  • Priority changed from 58 to 0
  • Regression set to No

Could not reproduce in 7.2.0. The reporting was ok. Closing the ticket, feel free to re-open it and add more details to reproduce.

Actions

Also available in: Atom PDF