Project

General

Profile

Actions

Bug #17314

closed

policy generation error when disabling " Enable syntax validation of generated policies" during a policy generation

Added by Nicolas CHARLES almost 4 years ago. Updated 8 months ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Web - Config management
Severity:
Minor - inconvenience | misleading | easy workaround
UX impact:
User visibility:
Operational - other Techniques | Rudder settings | Plugins
Effort required:
Priority:
0
Name check:
To do
Fix check:
To do
Regression:
No

Description

I disabled "Enable syntax validation of generated policies" during a policy generation, and I got

2020-05-04T04:52:59+0000 WARNING Failed to execute shell command from Rudder: error=13, Permission denied2020-05-04T04:52:59+0000 WARNING Failed to execute shell command from Rudder: error=13, Permission denied2020-05-04T04:52:59+0000 WARNING Failed to execute shell command from Rudder: error=13, Permission denied2020-05-04T04:52:59+0000 WARNING Failed to execute shell command from Rudder: error=13, Permission denied2020-05-04T04:52:59+0000 WARNING Failed to execute shell command from Rudder: error=13, Permission denied2020-05-04T04:52:59+0000 WARNING Failed to execute shell command from Rudder: error=13, Permission denied2020-05-04T04:52:59+0000 WARNING Failed to execute shell command from Rudder: error=13, Permission denied2020-05-04T04:52:59+0000 WARNING Failed to execute shell command from Rudder: error=13, Permission denied2020-05-04T04:52:59+0000 WARNING Failed to execute shell command from Rudder: error=13, Permission denied2020-05-04T04:52:59+0000 WARNING Failed to execute shell command from Rudder: error=13, Permission denied2020-05-04T04:52:59+0000 WARNING Failed to execute shell command from Rudder: error=13, Permission denied2020-05-04T04:52:59+0000 WARNING Failed to execute shell command from Rudder: error=13, Permission denied2020-05-04T04:52:59+0000 WARNING Failed to execute shell command from Rudder: error=13, Permission denied2020-05-04T04:52:59+0000 WARNING Failed to execute shell command from Rudder: error=13, Permission denied2020-05-04T04:53:00+0000 WARNING Failed to execute shell command from Rudder: error=13, Permission denied2020-05-04T04:53:00+0000 WARNING Failed to execute shell command from Rudder: error=13, Permission denied2020-05-04T04:53:00+0000 WARNING Failed to ex...
[2020-05-04 04:55:10] INFO  policy.generation.timing - Policy generation failed after: 30 min 36 s
[2020-05-04 04:55:10] ERROR policy.generation - Error when updating policy, reason was: Cannot write nodes configuration <- Unexpected: Error when executing hooks:
 Exit code=-2147483648 (check that file exists and is executable) for hook: '/opt/rudder/etc/hooks.d/policy-generation-node-ready/10-cf-promise-check'. [stdout:][stderr:] (for node(s) a368452b-35b4-4943-bdf3-fcbc14bb6d43;260c74d9-7062-4adb-b2b2-046043991907;421c8022-f493-4801-87eb-c9e1bb75d38d;2e803baa-3d23-4beb-be03-6afa609ff21b;2d20386d-7646-4028-acfc-ec43e03df8f2;9cf80981-7926-4cbd-9d38-2ae2bce3cc7f;c1a6e7bf-c89c-4e96-bef3-c7a285f29e03;1edbfc51-f0b8-4097-b6be-c2999e45fafd;91308052-1e0c-4

this was during the hooks execution


Related issues 1 (0 open1 closed)

Related to Rudder - Bug #15011: Error at the end of a policy generation with too many nodes ReleasedFrançois ARMANDActions
Actions #1

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 6.1.0~beta2 to 6.1.0~beta3
Actions #2

Updated by François ARMAND almost 4 years ago

  • Status changed from New to In progress
  • Assignee set to François ARMAND
Actions #3

Updated by François ARMAND almost 4 years ago

Could it happens that you changed the rights (the checkbox) during policy generation around the time we list what hooks are available? (it seems to be once policies are written, before we start checking and moving files around).

Actions #4

Updated by François ARMAND almost 4 years ago

  • Status changed from In progress to Discussion
  • Assignee deleted (François ARMAND)
  • Target version changed from 6.1.0~beta3 to 5.0.18
  • Severity set to Minor - inconvenience | misleading | easy workaround
  • User visibility set to Operational - other Techniques | Rudder settings | Plugins
  • Priority changed from 0 to 32

To make my previous comment clearer: I think the behavior is ok and I'm not sure we could prevent it anyway. To avoid thounsand of directory listing, we only check for available hooks once for each kind, just before they are first needed. But if the execution bit change before that listing and when it's used, then we get an error, and the error is correct.
On the setting side, it has zero idea that a generation is processing and just between the moment hooks were read and it is used.

In all case, it's not specific to 6.1.

Actions #5

Updated by Nicolas CHARLES almost 4 years ago

Yes, it was done during policy generation, when I realized that it was too slow.

Actions #6

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 5.0.18 to 5.0.19
Actions #7

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 5.0.19 to 5.0.20
  • Priority changed from 32 to 31
Actions #8

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 5.0.20 to 797
  • Priority changed from 31 to 30
Actions #9

Updated by Benoît PECCATTE almost 3 years ago

  • Target version changed from 797 to 6.1.14
  • Priority changed from 30 to 27
Actions #10

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #11

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #12

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #13

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #14

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #15

Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 6.1.19 to 6.1.20
Actions #16

Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 6.1.20 to 6.1.21
Actions #17

Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 6.1.21 to old 6.1 issues to relocate
Actions #18

Updated by Alexis Mousset about 1 year ago

  • Target version changed from old 6.1 issues to relocate to old 6.2 issues to relocate
  • Priority changed from 27 to 0
Actions #19

Updated by Alexis Mousset 8 months ago

  • Status changed from Discussion to Rejected
  • Regression set to No

let's consider it acceptable

Actions #20

Updated by François ARMAND 29 days ago

  • Related to Bug #15011: Error at the end of a policy generation with too many nodes added
Actions

Also available in: Atom PDF