Project

General

Profile

Actions

Bug #17653

closed

when a node is just accepted, on the node list there a warning sign that the system policy could not be applied

Added by Nicolas CHARLES about 4 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
N/A
Category:
Web - Compliance & node report
Target version:
Severity:
Minor - inconvenience | misleading | easy workaround
UX impact:
User visibility:
Getting started - demo | first install | Technique editor and level 1 Techniques
Effort required:
Small
Priority:
55
Name check:
To do
Fix check:
To do
Regression:

Description

this message should only happen after the grace period


Related issues 1 (1 open0 closed)

Is duplicate of Rudder - Bug #8761: New nodes have compliance warning for system technique just after being addedNewActions
Actions #1

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 6.1.0~rc3 to 6.1.0~rc4
Actions #3

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 6.1.0~rc4 to 6.1.0
Actions #4

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 6.1.0 to 6.1.1
Actions #6

Updated by François ARMAND almost 4 years ago

  • Severity set to Minor - inconvenience | misleading | easy workaround
  • User visibility set to Getting started - demo | first install | Technique editor and level 1 Techniques
  • Effort required set to Small
  • Priority changed from 0 to 66

I think it's because just after acceptation, there's no configuration at all for that node (generation not finished), so the compliance doesn't know it is in grace period yet.

We could have a special case that checks for acceptation time if there is no config yet, and set to "pending" in that case.

Actions #7

Updated by Nicolas CHARLES almost 4 years ago

policy generation was done, but reports were not received

Actions #8

Updated by François ARMAND almost 4 years ago

Elaad, when you will be working on that one, the first steps will be:

- add a log like that:

  <logger name="explain_compliance.node_uuid_that_will_be_accepted" level="trace"/>

- reproduce the problem,
- add screenshot of the message explanation message node details compliance tab, and add logs here.

If you get stuck when trying to understand the problem, ask for help.

Actions #9

Updated by François ARMAND almost 4 years ago

  • Assignee set to Elaad FURREEDAN
Actions #11

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 6.1.1 to 6.1.2
Actions #12

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 6.1.2 to 6.1.3
  • Priority changed from 66 to 65
Actions #13

Updated by François ARMAND almost 4 years ago

  • Target version changed from 6.1.3 to 6.1.4
Actions #14

Updated by Elaad FURREEDAN almost 4 years ago

  • Status changed from New to In progress
  • Priority changed from 65 to 64
Actions #15

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 6.1.4 to 6.1.5
Actions #16

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.5 to 6.1.6
  • Priority changed from 64 to 63
Actions #17

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.6 to 6.1.7
  • Priority changed from 63 to 62
Actions #18

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.7 to 6.1.8
  • Priority changed from 62 to 61
Actions #19

Updated by Elaad FURREEDAN over 3 years ago

  • Status changed from In progress to New
Actions #20

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.8 to 6.1.9
  • Priority changed from 61 to 59
Actions #21

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.9 to 6.1.10
Actions #22

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.10 to 6.1.11
  • Priority changed from 59 to 58
Actions #23

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.11 to 6.1.12
Actions #24

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.12 to 6.1.13
  • Priority changed from 58 to 57
Actions #25

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.13 to 6.1.14
  • Priority changed from 57 to 56
Actions #26

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
  • Priority changed from 56 to 55
Actions #27

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #28

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #29

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #30

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #31

Updated by François ARMAND over 2 years ago

  • Is duplicate of Bug #8761: New nodes have compliance warning for system technique just after being added added
Actions #32

Updated by François ARMAND over 2 years ago

  • Status changed from New to Rejected

Closing as duplicate of #8761

Actions

Also available in: Atom PDF