Project

General

Profile

Bug #17699

Rudder-agent needs libxml-treepp-perl dependency to work on minimal Debian

Added by Vincent MEMBRÉ 4 months ago. Updated 2 months ago.

Status:
Released
Priority:
N/A
Category:
Packaging
Target version:
Severity:
User visibility:
Effort required:
Priority:
0

Description

We needs to depends on libxml-treepp-perl for all debian using system perl.

We did #12599 for Debian 9, but other minimal debian image fails to achieve their inventory (like Florian said here: https://issues.rudder.io/issues/12599#note-23)

#1

Updated by Vincent MEMBRÉ 4 months ago

  • Status changed from New to In progress
#2

Updated by Vincent MEMBRÉ 4 months ago

  • Assignee changed from Vincent MEMBRÉ to Benoît PECCATTE
  • Pull Request set to https://github.com/Normation/rudder-packages/pull/2316
#3

Updated by Vincent MEMBRÉ 4 months ago

  • Subject changed from Minimal debian needs libxml-treepp-perl to Minimal debian needs libxml-treepp-perl depedency
#4

Updated by Vincent MEMBRÉ 4 months ago

  • Subject changed from Minimal debian needs libxml-treepp-perl depedency to Rudder-agent needs libxml-treepp-perl dependency to work on minimal Debian
#5

Updated by Vincent MEMBRÉ 4 months ago

  • Status changed from In progress to Pending release
#7

Updated by Vincent MEMBRÉ 2 months ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 5.0.18 and 6.1.2 which were released today.

Also available in: Atom PDF