Project

General

Profile

Actions

Bug #17810

closed

Remaining files after agent uninstall

Added by François ARMAND almost 4 years ago. Updated 10 months ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Packaging
Severity:
Minor - inconvenience | misleading | easy workaround
UX impact:
User visibility:
Operational - other Techniques | Rudder settings | Plugins
Effort required:
Priority:
0
Name check:
To do
Fix check:
To do
Regression:
No

Description

These files are remaning (on centos 8) after agent version 5.0.13 is uninstalled:

  • /etc/systemd/system/rudder-agent.service.requires
  • /etc/systemd/system/rudder-agent.service.wants
  • /etc/systemd/system/multi-user.target.wants/rudder-agent.service
  • /etc/systemd/system/multi-user.target.wants/rudder-cf-execd.service
  • /etc/systemd/system/multi-user.target.wants/rudder-cf-serverd.service
  • /etc/systemd/system/rudder-agent.service.requires/rudder-cf-execd.service
  • /etc/systemd/system/rudder-agent.service.wants/rudder-cf-serverd.service
For server, you may also have:
  • /etc/systemd/system/multi-user.target.wants/rudder-relayd.service
  • /etc/systemd/system/multi-user.target.wants/rudder-jetty.service
  • /etc/systemd/system/multi-user.target.wants/rudder-slapd.service
  • /etc/systemd/system/multi-user.target.wants/rudder-server.service
  • /etc/systemd/system/rudder-server.service.requires
  • /etc/systemd/system/rudder-server.service.requires/rudder-relayd.service
  • /etc/systemd/system/rudder-server.service.requires/rudder-jetty.service
  • /etc/systemd/system/rudder-server.service.requires/rudder-slapd.service

Sometimes, depending on package installation update history, you get:

  • /etc/cron.d/rudder-agent.rpmsave

On some (old) version of agent, you can get:

  • /etc/cron.d/rudder-agent
  • /etc/profile.d/rudder-agent.sh
  • /etc/rsyslog.d/rudder-agent.conf

Workaround:

- /etc/cron.d/rudder-agent.rpmsave, /etc/cron.d/rudder-agent, /etc/profile.d/rudder-agent.sh and /etc/rsyslog.d/rudder-agent.conf can be deleted,
- systemd files can be removed by systemd. For each service, you need to do: systemctl disable $service, starting by deeper ones:

systemctl disable rudder-cf-serverd
systemctl disable rudder-cf-execd
systemctl disable rudder-agent
systemctl disable rudder-relayd
systemctl disable rudder-jetty
systemctl disable rudder-slapd
systemctl disable rudder-server

If these systemctl commands don't work, you can delete these file with rm, then reload systemd config:

systemctl daemon-reload

Related issues 1 (0 open1 closed)

Is duplicate of Rudder - Bug #23146: Actually allow uninstalling the agentReleasedBenoît PECCATTEActions
Actions #1

Updated by François ARMAND almost 4 years ago

  • Description updated (diff)
Actions #2

Updated by François ARMAND almost 4 years ago

  • Description updated (diff)
Actions #3

Updated by François ARMAND almost 4 years ago

  • Translation missing: en.field_tag_list deleted (Sponsored)
  • Priority changed from 65 to 32
Actions #4

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.18 to 5.0.19
Actions #5

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.19 to 5.0.20
Actions #6

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 5.0.20 to 797
  • Priority changed from 32 to 31
Actions #7

Updated by Benoît PECCATTE almost 3 years ago

  • Target version changed from 797 to 6.1.14
  • Priority changed from 31 to 27
Actions #8

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #9

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #10

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #11

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #12

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #13

Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 6.1.19 to 6.1.20
Actions #14

Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 6.1.20 to 6.1.21
Actions #15

Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 6.1.21 to old 6.1 issues to relocate
Actions #16

Updated by Alexis Mousset over 1 year ago

  • Target version changed from old 6.1 issues to relocate to old 6.2 issues to relocate
  • Priority changed from 27 to 0
Actions #17

Updated by Alexis Mousset 10 months ago

  • Status changed from New to Rejected
  • Regression set to No
Actions #18

Updated by Alexis Mousset 10 months ago

  • Is duplicate of Bug #23146: Actually allow uninstalling the agent added
Actions

Also available in: Atom PDF