Project

General

Profile

Actions

Bug #17857

closed

error when installing rudder server 6.0.8~rc1~git202006290335-debian9

Added by Nicolas CHARLES almost 4 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Packaging
Target version:
Severity:
Major - prevents use of part of Rudder | no simple workaround
UX impact:
User visibility:
Getting started - demo | first install | Technique editor and level 1 Techniques
Effort required:
Priority:
58
Name check:
To do
Fix check:
To do
Regression:

Description

   debian9_server: Updating Rudder password file with random passwords... 
    debian9_server:  done.
    debian9_server: Cleaning up temporary directories...
    debian9_server:  done.
    debian9_server: Restarting jetty...
    debian9_server:  done.
    debian9_server: 
    debian9_server: Reinitialization complete, Rudder is currently reloading.
    debian9_server: 
    debian9_server: You can access it via https://server.rudder.local/rudder
    debian9_server: INFO: Launching script to check if a migration is needed ...
    debian9_server: Done
    debian9_server: INFO: Make sure Rudder webapp is started...
    debian9_server:  Done
    debian9_server: INFO: Make sure Apache HTTPd is started...
    debian9_server:  Done
    debian9_server: INFO: Agent certificate is missing, creating it...
    debian9_server:  Done
    debian9_server: INFO: No disable file detected and no agent executor process either. Restarting agent service...
    debian9_server: rudder-cf-serverd: enabled
    debian9_server: rudder-cf-execd: enabled
    debian9_server: ok: stop service rudder-agent succeeded
    debian9_server: rudder-cf-serverd: enabled
    debian9_server: rudder-cf-execd: enabled
    debian9_server: ok: start service rudder-agent succeeded
    debian9_server:  Done
    debian9_server: INFO: Inventory older than 3 days, resending ...
    debian9_server: Rudder agent 6.0.8~rc1~git202006290335-debian9
    debian9_server: Node uuid: root
    debian9_server: Start execution with config [20200629-122326-508a063f]
    debian9_server: 
    debian9_server: M| State         Technique                 Component                 Key                Message
    debian9_server: E| error         Inventory                 inventory                                    Could not send the inventory
    debian9_server: info     Rudder agent was run on a subset of policies - not all policies were checked
    debian9_server: 
    debian9_server: ## Summary #####################################################################
    debian9_server: 1 components verified in 3 directives
    debian9_server:    => 1 components in Enforce mode
    debian9_server:       -> 1 error
    debian9_server: Execution time: 3.52s
    debian9_server: ################################################################################
    debian9_server: warning: Could not send /var/rudder/reports/ready//2020-06-29T10:23:53+00:00@root.log.gz, it will be retried later

inventory have selfhealed, being sent at 12:26 while error was at 12:23
Actions #1

Updated by Vincent MEMBRÉ almost 4 years ago

I encountered the same issue on a ubuntu 18 server. but it did not self healed and i could have any reporting working because of this (no certificate to use with relayd)

Actions #2

Updated by Vincent MEMBRÉ almost 4 years ago

  • Status changed from New to In progress
  • Assignee set to Vincent MEMBRÉ
Actions #3

Updated by Vincent MEMBRÉ almost 4 years ago

  • Status changed from In progress to New
  • Assignee deleted (Vincent MEMBRÉ)
Actions #4

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 6.0.7 to 6.0.8
Actions #5

Updated by François ARMAND almost 4 years ago

  • Severity set to Major - prevents use of part of Rudder | no simple workaround
  • User visibility set to Getting started - demo | first install | Technique editor and level 1 Techniques
  • Priority changed from 0 to 70
Actions #6

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 6.0.8 to 6.0.9
Actions #7

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.0.9 to 6.0.10
  • Priority changed from 70 to 68
Actions #8

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.0.10 to 798
  • Priority changed from 68 to 66
Actions #9

Updated by Benoît PECCATTE almost 3 years ago

  • Target version changed from 798 to 6.1.14
  • Priority changed from 66 to 58
Actions #10

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #11

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #12

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #13

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #14

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #15

Updated by Alexis Mousset over 2 years ago

  • Status changed from New to Rejected

not reported since 6.0, which is not maintained anymore, closing.

Actions

Also available in: Atom PDF