Project

General

Profile

Actions

Bug #17884

closed

Bug #17882: Shared-files correction in postinst must be recursive

Error when installing relayd on root: missing file /var/rudder/configuration-repository/shared-files/*

Added by François ARMAND over 2 years ago. Updated over 2 years ago.

Status:
Released
Priority:
N/A
Category:
System integration
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Regression:

Description

Something try to access /var/rudder/configuration-repository/shared-files during relayd installation on root, and it fails because it doesn't exists. Creating it allows to end installation.

Actions #1

Updated by Vincent MEMBRÉ over 2 years ago

  • Status changed from New to Rejected

Duplicates #17882

Actions #2

Updated by Vincent MEMBRÉ over 2 years ago

  • Related to Bug #17882: Shared-files correction in postinst must be recursive added
Actions #3

Updated by Vincent MEMBRÉ over 2 years ago

  • Related to deleted (Bug #17882: Shared-files correction in postinst must be recursive)
Actions #4

Updated by Vincent MEMBRÉ over 2 years ago

  • Subject changed from Error when installing relayd on root: missing file /var/rudder/configuration-repository/shared-files to Error when installing relayd on root: missing file /var/rudder/configuration-repository/shared-files/*
  • Status changed from Rejected to New
  • Parent task set to #17882

This fails on install, since command

chmod -R u+rwx,g+rX /var/rudder/configuration-repository/shared-files/*

fails if the directory is empty (also on upgrade if this is empty)

Actions #5

Updated by Vincent MEMBRÉ over 2 years ago

  • Status changed from New to In progress
  • Assignee changed from Félix DALLIDET to Vincent MEMBRÉ
Actions #6

Updated by Vincent MEMBRÉ over 2 years ago

  • Assignee changed from Vincent MEMBRÉ to Alexis Mousset
  • Pull Request set to https://github.com/Normation/rudder/pull/3112
Actions #7

Updated by Vincent MEMBRÉ over 2 years ago

  • Status changed from In progress to Pending release
Actions #8

Updated by Vincent MEMBRÉ over 2 years ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 6.0.7 and 6.1.1 which were released today.

Actions

Also available in: Atom PDF