Project

General

Profile

Actions

Bug #18065

closed

Upgrade error from 5.0 to 6.1 on sles12

Added by François ARMAND almost 4 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Packaging
Target version:
Severity:
Minor - inconvenience | misleading | easy workaround
UX impact:
User visibility:
Operational - other Techniques | Rudder settings | Plugins
Effort required:
Priority:
27
Name check:
To do
Fix check:
To do
Regression:

Description

Error seems related to apache:

There is not much in journald about that:

Jul 29 15:30:12 server crontab[16713]: (root) DELETE (ncf-api-venv)
Jul 29 15:30:12 server userdel[16711]: delete user 'ncf-api-venv'
Jul 29 15:30:12 server userdel[16711]: delete 'ncf-api-venv' from group 'rudder'
...
Jul 29 15:30:12 server rudder-slapd[16777]: slapd starting
Jul 29 15:30:12 server rudder-server[16774]: Starting Rudder services:
Jul 29 15:30:12 server start_apache2[16802]: [Wed Jul 29 15:30:12.981717 2020] [so:warn] [pid 16802] AH01574: module dav_module is already loaded, skipping
Jul 29 15:30:12 server rudder-server[16774]: * rudder-slapd...        OK
Jul 29 15:30:12 server start_apache2[16802]: [Wed Jul 29 15:30:12.987423 2020] [so:warn] [pid 16802] AH01574: module dav_fs_module is already loaded, skipping
Jul 29 15:30:12 server start_apache2[16802]: [Wed Jul 29 15:30:12.987620 2020] [so:warn] [pid 16802] AH01574: module ssl_module is already loaded, skipping
Jul 29 15:30:12 server start_apache2[16802]: [Wed Jul 29 15:30:12.987762 2020] [so:warn] [pid 16802] AH01574: module version_module is already loaded, skipping
Jul 29 15:30:12 server start_apache2[16802]: [Wed Jul 29 15:30:12.988333 2020] [so:warn] [pid 16802] AH01574: module rewrite_module is already loaded, skipping
Jul 29 15:30:12 server start_apache2[16802]: [Wed Jul 29 15:30:12.988543 2020] [so:warn] [pid 16802] AH01574: module dav_module is already loaded, skipping
Jul 29 15:30:12 server start_apache2[16802]: [Wed Jul 29 15:30:12.988682 2020] [so:warn] [pid 16802] AH01574: module dav_fs_module is already loaded, skipping
Jul 29 15:30:12 server start_apache2[16802]: [Wed Jul 29 15:30:12.988820 2020] [so:warn] [pid 16802] AH01574: module proxy_module is already loaded, skipping
Jul 29 15:30:12 server start_apache2[16802]: [Wed Jul 29 15:30:12.988953 2020] [so:warn] [pid 16802] AH01574: module proxy_http_module is already loaded, skipping
Jul 29 15:30:12 server start_apache2[16802]: [Wed Jul 29 15:30:12.989185 2020] [so:warn] [pid 16802] AH01574: module ssl_module is already loaded, skipping
Jul 29 15:30:12 server start_apache2[16802]: [Wed Jul 29 15:30:12.989329 2020] [so:warn] [pid 16802] AH01574: module version_module is already loaded, skipping
Jul 29 15:30:12 server start_apache2[16802]: AH00543: httpd-prefork: bad user name ncf-api-venv
Jul 29 15:30:13 server rudder-server[16774]: * postgresql...        OK
Jul 29 15:30:13 server rudder-jetty.sh[16788]: Setting umask to 0007
Jul 29 15:30:13 server start_apache2[16843]: [Wed Jul 29 15:30:13.105854 2020] [so:warn] [pid 16843] AH01574: module dav_module is already loaded, skipping
Jul 29 15:30:13 server start_apache2[16843]: [Wed Jul 29 15:30:13.106123 2020] [so:warn] [pid 16843] AH01574: module dav_fs_module is already loaded, skipping
Jul 29 15:30:13 server start_apache2[16843]: [Wed Jul 29 15:30:13.106268 2020] [so:warn] [pid 16843] AH01574: module ssl_module is already loaded, skipping
Jul 29 15:30:13 server start_apache2[16843]: [Wed Jul 29 15:30:13.106414 2020] [so:warn] [pid 16843] AH01574: module version_module is already loaded, skipping
Jul 29 15:30:13 server start_apache2[16843]: [Wed Jul 29 15:30:13.106842 2020] [so:warn] [pid 16843] AH01574: module rewrite_module is already loaded, skipping
Jul 29 15:30:13 server start_apache2[16843]: [Wed Jul 29 15:30:13.106992 2020] [so:warn] [pid 16843] AH01574: module dav_module is already loaded, skipping
Jul 29 15:30:13 server start_apache2[16843]: [Wed Jul 29 15:30:13.107129 2020] [so:warn] [pid 16843] AH01574: module dav_fs_module is already loaded, skipping
Jul 29 15:30:13 server start_apache2[16843]: [Wed Jul 29 15:30:13.107330 2020] [so:warn] [pid 16843] AH01574: module proxy_module is already loaded, skipping
Jul 29 15:30:13 server start_apache2[16843]: [Wed Jul 29 15:30:13.107337 2020] [so:warn] [pid 16843] AH01574: module proxy_http_module is already loaded, skipping
Jul 29 15:30:13 server start_apache2[16843]: [Wed Jul 29 15:30:13.107400 2020] [so:warn] [pid 16843] AH01574: module ssl_module is already loaded, skipping
Jul 29 15:30:13 server start_apache2[16843]: [Wed Jul 29 15:30:13.107406 2020] [so:warn] [pid 16843] AH01574: module version_module is already loaded, skipping
Jul 29 15:30:13 server start_apache2[16843]: AH00543: httpd-prefork: bad user name ncf-api-venv
Jul 29 15:30:14 server start_apache2[17305]: [Wed Jul 29 15:30:14.454436 2020] [so:warn] [pid 17305] AH01574: module dav_module is already loaded, skipping
Jul 29 15:30:14 server start_apache2[17305]: [Wed Jul 29 15:30:14.454730 2020] [so:warn] [pid 17305] AH01574: module dav_fs_module is already loaded, skipping
Jul 29 15:30:14 server start_apache2[17305]: [Wed Jul 29 15:30:14.454876 2020] [so:warn] [pid 17305] AH01574: module ssl_module is already loaded, skipping
Jul 29 15:30:14 server start_apache2[17305]: [Wed Jul 29 15:30:14.455013 2020] [so:warn] [pid 17305] AH01574: module version_module is already loaded, skipping
Jul 29 15:30:14 server start_apache2[17305]: [Wed Jul 29 15:30:14.455432 2020] [so:warn] [pid 17305] AH01574: module rewrite_module is already loaded, skipping
Jul 29 15:30:14 server start_apache2[17305]: [Wed Jul 29 15:30:14.455583 2020] [so:warn] [pid 17305] AH01574: module dav_module is already loaded, skipping
Jul 29 15:30:14 server start_apache2[17305]: [Wed Jul 29 15:30:14.455722 2020] [so:warn] [pid 17305] AH01574: module dav_fs_module is already loaded, skipping
Jul 29 15:30:14 server start_apache2[17305]: [Wed Jul 29 15:30:14.455859 2020] [so:warn] [pid 17305] AH01574: module proxy_module is already loaded, skipping
Jul 29 15:30:14 server start_apache2[17305]: [Wed Jul 29 15:30:14.455993 2020] [so:warn] [pid 17305] AH01574: module proxy_http_module is already loaded, skipping
Jul 29 15:30:14 server start_apache2[17305]: [Wed Jul 29 15:30:14.456182 2020] [so:warn] [pid 17305] AH01574: module ssl_module is already loaded, skipping
Jul 29 15:30:14 server start_apache2[17305]: [Wed Jul 29 15:30:14.456324 2020] [so:warn] [pid 17305] AH01574: module version_module is already loaded, skipping
Jul 29 15:30:14 server rudder-server[16774]: * rudder-jetty...

So it looks like it delete user ncf-api-env and don't have an updated configuration for apache.

Running /opt/rudder/etc/bin/rudder-upgrade by hand, as suggested, solved the problem.


Files

clipboard-202007300950-3knku.png (19.5 KB) clipboard-202007300950-3knku.png François ARMAND, 2020-07-30 09:50
Actions #1

Updated by François ARMAND almost 4 years ago

  • Target version changed from 6.1.3 to 6.1.4
Actions #2

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 6.1.4 to 6.1.5
Actions #3

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.5 to 6.1.6
Actions #4

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.6 to 6.1.7
  • Priority changed from 32 to 31
Actions #5

Updated by Nicolas CHARLES over 3 years ago

it still happens

2020-10-27T10:23:02.904898+01:00 server start_apache2[7761]: AH00543: httpd-prefork: bad user name ncf-api-venv

Actions #6

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.7 to 6.1.8
Actions #7

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.8 to 6.1.9
  • Priority changed from 31 to 30
Actions #8

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.9 to 6.1.10
Actions #9

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.10 to 6.1.11
  • Priority changed from 30 to 29
Actions #10

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.11 to 6.1.12
Actions #11

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.12 to 6.1.13
Actions #12

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.13 to 6.1.14
  • Priority changed from 29 to 28
Actions #13

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
  • Priority changed from 28 to 27
Actions #14

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #15

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #16

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #17

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #18

Updated by Alexis Mousset over 2 years ago

  • Status changed from New to Rejected

5.0 is not supported anymore.

Actions

Also available in: Atom PDF