Project

General

Profile

Actions

Bug #18187

closed

After upgrading from 6.0 to 6.1 on centos7, reports are not arriving on the server temporarly

Added by Nicolas CHARLES almost 4 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Packaging
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Name check:
To do
Fix check:
To do
Regression:

Description

On the relay, I have following messages

Sep 09 14:15:10 relay rudder-relayd[6430]: ERROR relayd::processing::reporting: output error: HTTP error: https://server/reports/2020-09-09T14:09:08+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz: Client Error: 401 Unauthorized
Sep 09 14:15:10 relay rudder-relayd[6430]: INFO relayd::processing::reporting: transient error, skipping
Sep 09 14:15:10 relay rudder-relayd[6430]: ERROR relayd::processing::reporting: output error: HTTP error: https://server/reports/2020-09-09T14:13:22+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz: Client Error: 401 Unauthorized
Sep 09 14:15:10 relay rudder-relayd[6430]: INFO relayd::processing::reporting: transient error, skipping
Sep 09 14:15:20 relay rudder-relayd[6430]: ERROR relayd::processing::reporting: output error: HTTP error: https://server/reports/2020-09-09T14:09:08+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz: Client Error: 401 Unauthorized
Sep 09 14:15:20 relay rudder-relayd[6430]: INFO relayd::processing::reporting: transient error, skipping
Sep 09 14:15:20 relay rudder-relayd[6430]: ERROR relayd::processing::reporting: output error: HTTP error: https://server/reports/2020-09-09T14:13:22+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz: Client Error: 401 Unauthorized
Sep 09 14:15:20 relay rudder-relayd[6430]: INFO relayd::processing::reporting: transient error, skipping
Sep 09 14:15:30 relay rudder-relayd[6430]: ERROR relayd::processing::reporting: output error: HTTP error: https://server/reports/2020-09-09T14:09:08+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz: Client Error: 401 Unauthorized
Sep 09 14:15:30 relay rudder-relayd[6430]: INFO relayd::processing::reporting: transient error, skipping
Sep 09 14:15:30 relay rudder-relayd[6430]: ERROR relayd::processing::reporting: output error: HTTP error: https://server/reports/2020-09-09T14:13:22+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz: Client Error: 401 Unauthorized
Sep 09 14:15:30 relay rudder-relayd[6430]: INFO relayd::processing::reporting: transient error, skipping
Sep 09 14:15:40 relay rudder-relayd[6430]: ERROR relayd::processing::reporting: output error: HTTP error: https://server/reports/2020-09-09T14:09:08+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz: Client Error: 401 Unauthorized
Sep 09 14:15:40 relay rudder-relayd[6430]: INFO relayd::processing::reporting: transient error, skipping
Sep 09 14:15:40 relay rudder-relayd[6430]: ERROR relayd::processing::reporting: output error: HTTP error: https://server/reports/2020-09-09T14:13:22+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz: Client Error: 401 Unauthorized
Sep 09 14:15:40 relay rudder-relayd[6430]: INFO relayd::processing::reporting: transient error, skipping
Sep 09 14:15:47 relay systemd[1]: Stopping Rudder Relay Daemon...
Sep 09 14:15:47 relay rudder-relayd[6430]: INFO relayd: Signal received: shutdown requested
Sep 09 14:15:47 relay systemd[1]: Stopped Rudder Relay Daemon.
Sep 09 14:15:47 relay systemd[1]: Started Rudder Relay Daemon.

on server side, /opt/rudder/etc/rudder-networks-24.conf get the following lines added

+Require ip fe80::a00:27ff:fe3d:8385
+Require ip fe80::a00:27ff:fe4f:aa77

but also

[Wed Sep 09 14:13:47.997102 2020] [proxy_http:error] [pid 21632] [client 192.168.41.1:34698] AH01114: HTTP: failed to make connection to backend: localhost, referer: https://192.168.41.2/rudder/secure/index.html
[Wed Sep 09 14:13:50.725433 2020] [auth_basic:error] [pid 21748] [client 192.168.41.3:53980] AH01617: user rudder: authentication failure for "/reports/2020-09-09T14:09:08+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz": Password Mismatch
[Wed Sep 09 14:14:00.705194 2020] [auth_basic:error] [pid 24513] [client 192.168.41.3:53982] AH01617: user rudder: authentication failure for "/reports/2020-09-09T14:09:08+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz": Password Mismatch
[Wed Sep 09 14:14:00.705564 2020] [auth_basic:error] [pid 21621] [client 192.168.41.3:53984] AH01617: user rudder: authentication failure for "/reports/2020-09-09T14:13:22+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz": Password Mismatch
[Wed Sep 09 14:14:10.723337 2020] [auth_basic:error] [pid 21749] [client 192.168.41.3:53986] AH01617: user rudder: authentication failure for "/reports/2020-09-09T14:09:08+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz": Password Mismatch
[Wed Sep 09 14:14:10.724653 2020] [auth_basic:error] [pid 24474] [client 192.168.41.3:53988] AH01617: user rudder: authentication failure for "/reports/2020-09-09T14:13:22+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz": Password Mismatch
[Wed Sep 09 14:14:20.733369 2020] [auth_basic:error] [pid 21720] [client 192.168.41.3:53990] AH01617: user rudder: authentication failure for "/reports/2020-09-09T14:09:08+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz": Password Mismatch
[Wed Sep 09 14:14:20.735375 2020] [auth_basic:error] [pid 24512] [client 192.168.41.3:53992] AH01617: user rudder: authentication failure for "/reports/2020-09-09T14:13:22+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz": Password Mismatch
[Wed Sep 09 14:14:30.719612 2020] [auth_basic:error] [pid 24513] [client 192.168.41.3:53994] AH01617: user rudder: authentication failure for "/reports/2020-09-09T14:09:08+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz": Password Mismatch
[Wed Sep 09 14:14:30.721405 2020] [auth_basic:error] [pid 21632] [client 192.168.41.3:53996] AH01617: user rudder: authentication failure for "/reports/2020-09-09T14:13:22+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz": Password Mismatch
[Wed Sep 09 14:14:40.720147 2020] [auth_basic:error] [pid 21620] [client 192.168.41.3:53998] AH01617: user rudder: authentication failure for "/reports/2020-09-09T14:09:08+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz": Password Mismatch
[Wed Sep 09 14:14:40.721357 2020] [auth_basic:error] [pid 21618] [client 192.168.41.3:54000] AH01617: user rudder: authentication failure for "/reports/2020-09-09T14:13:22+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz": Password Mismatch
[Wed Sep 09 14:14:50.721609 2020] [auth_basic:error] [pid 24474] [client 192.168.41.3:54002] AH01617: user rudder: authentication failure for "/reports/2020-09-09T14:09:08+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz": Password Mismatch
[Wed Sep 09 14:14:50.723561 2020] [auth_basic:error] [pid 21749] [client 192.168.41.3:54004] AH01617: user rudder: authentication failure for "/reports/2020-09-09T14:13:22+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz": Password Mismatch
[Wed Sep 09 14:15:00.710942 2020] [auth_basic:error] [pid 21748] [client 192.168.41.3:54006] AH01617: user rudder: authentication failure for "/reports/2020-09-09T14:09:08+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz": Password Mismatch
[Wed Sep 09 14:15:00.711457 2020] [auth_basic:error] [pid 24474] [client 192.168.41.3:54008] AH01617: user rudder: authentication failure for "/reports/2020-09-09T14:13:22+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz": Password Mismatch
[Wed Sep 09 14:15:10.713381 2020] [auth_basic:error] [pid 25439] [client 192.168.41.3:54010] AH01617: user rudder: authentication failure for "/reports/2020-09-09T14:09:08+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz": Password Mismatch
[Wed Sep 09 14:15:10.714438 2020] [auth_basic:error] [pid 25440] [client 192.168.41.3:54012] AH01617: user rudder: authentication failure for "/reports/2020-09-09T14:13:22+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz": Password Mismatch
[Wed Sep 09 14:15:20.709485 2020] [auth_basic:error] [pid 25441] [client 192.168.41.3:54014] AH01617: user rudder: authentication failure for "/reports/2020-09-09T14:09:08+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz": Password Mismatch
[Wed Sep 09 14:15:20.710220 2020] [auth_basic:error] [pid 21620] [client 192.168.41.3:54016] AH01617: user rudder: authentication failure for "/reports/2020-09-09T14:13:22+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz": Password Mismatch
[Wed Sep 09 14:15:30.714480 2020] [auth_basic:error] [pid 24513] [client 192.168.41.3:54018] AH01617: user rudder: authentication failure for "/reports/2020-09-09T14:09:08+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz": Password Mismatch
[Wed Sep 09 14:15:30.715834 2020] [auth_basic:error] [pid 21621] [client 192.168.41.3:54020] AH01617: user rudder: authentication failure for "/reports/2020-09-09T14:13:22+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz": Password Mismatch
[Wed Sep 09 14:15:40.725070 2020] [auth_basic:error] [pid 21632] [client 192.168.41.3:54022] AH01617: user rudder: authentication failure for "/reports/2020-09-09T14:09:08+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz": Password Mismatch
[Wed Sep 09 14:15:40.727014 2020] [auth_basic:error] [pid 21748] [client 192.168.41.3:54024] AH01617: user rudder: authentication failure for "/reports/2020-09-09T14:13:22+00:00@9677ab7b-264d-4c99-bbe0-e0d84e5c9d23.log.gz": Password Mismatch
[Wed Sep 09 14:15:46.607371 2020] [auth_basic:error] [pid 21618] [client 192.168.41.3:54030] AH01617: user rudder: authentication failure for "/reports/2020-09-09T14:10:44+00:00@7c57ce75-41d2-4cf1-b3f7-ed7acf703cec.log.gz": Password Mismatch
[Wed Sep 09 14:15:50.632648 2020] [auth_basic:error] [pid 25440] [client 192.168.41.3:54042] AH01617: user rudder: authentication failure for "/inventory-updates/relay-7c57ce75-41d2-4cf1-b3f7-ed7acf703cec.ocs.sign": Password Mismatch
[Wed Sep 09 14:15:50.655682 2020] [auth_basic:error] [pid 25441] [client 192.168.41.3:54044] AH01617: user rudder: authentication failure for "/inventory-updates/relay-7c57ce75-41d2-4cf1-b3f7-ed7acf703cec.ocs.gz": Password Mismatch

Actions #1

Updated by Nicolas CHARLES almost 4 years ago

this is because policy generation was made late, because plugin scale-out-relay needed to be upgraded

Actions #2

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.5 to 6.1.6
Actions #3

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.6 to 6.1.7
Actions #4

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.7 to 6.1.8
Actions #5

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.8 to 6.1.9
Actions #6

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.9 to 6.1.10
Actions #7

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.10 to 6.1.11
Actions #8

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.11 to 6.1.12
Actions #9

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.12 to 6.1.13
Actions #10

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.13 to 6.1.14
Actions #11

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #12

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #13

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #14

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #15

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #16

Updated by Alexis Mousset over 2 years ago

plugin upgrade are not automatically done.

In the case of impossibility to generate policies there is not much we can do to apply new system techniques.

Actions #17

Updated by Alexis Mousset over 2 years ago

  • Status changed from New to Rejected
Actions

Also available in: Atom PDF