Project

General

Profile

Actions

Bug #18304

closed

Transcient errors message on agent run on server after upgrade from 6.0 to 6.1 on centos8

Added by Nicolas CHARLES over 3 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
System techniques
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Name check:
To do
Fix check:
To do
Regression:

Description

Running the agent outputs, the first time

E| compliant     server-roles              Check jetty process                          jetty service running was correct
E| compliant     server-roles              Check jetty boot script                      jetty service enabled was correct
   error: Object '/var/rudder/cfengine-community/ppkeys/root-MD5=9095d4a9a5aae7fd589e60db0684adc2.pub' exists and is obstructing our promise
   error: Unable to create link '/var/rudder/cfengine-community/ppkeys/root-MD5=9095d4a9a5aae7fd589e60db0684adc2.pub' -> '/var/rudder/cfengine-community/ppkeys/localhost.pub', failed to move obstruction
   info          Common                    Check jetty process       /var/rudder/cfeng| Symlink /var/rudder/cfengine-community/ppkeys/root-MD5=9095d4a9a5aae7fd589e60db0684adc2.pub targeting /var/rudder/cfengine-community/ppkeys/localhost.pub could not be repaired
   error: Method 'file_symlink_present_option' failed in some repairs
   info          Common                    Check jetty process       /var/rudder/cfeng| Symlink /var/rudder/cfengine-community/ppkeys/root-MD5=9095d4a9a5aae7fd589e60db0684adc2.pub targeting /var/rudder/cfengine-community/ppkeys/localhost.pub could not be repaired
   error: Method 'file_create_symlink_enforce' failed in some repairs
   info          Common                    Check jetty process       /var/rudder/cfeng| Symlink /var/rudder/cfengine-community/ppkeys/root-MD5=9095d4a9a5aae7fd589e60db0684adc2.pub targeting /var/rudder/cfengine-community/ppkeys/localhost.pub (without overwrite) could not be repaired
   error: Method 'file_create_symlink' failed in some repairs
E| compliant     server-roles              Check configuration-repo|                    The /var/rudder/configuration-repository directory is present
E| compliant     server-roles              Check configuration-repo|                    The /var/rudder/configuration-repository git lock file is not present or not older than 5 minutes
   error: Method 'root_integrity_check' failed in some repairs
rudder     info: Executing 'no timeout' ... '/usr/bin/curl --proxy '' --max-time 240 -s http://localhost:8080/rudder/api/status |/bin/grep -q OK'
rudder     info: Automatically promoting context scope for 'site_ok' to namespace visibility, due to persistence
rudder     info: Completed execution of '/usr/bin/curl --proxy '' --max-time 240 -s http://localhost:8080/rudder/api/status |/bin/grep -q OK'
E| compliant     server-roles              Check rudder status                          The http://localhost:8080/rudder/api/status web interface is running

Actions #1

Updated by Nicolas CHARLES over 3 years ago

next run doesn't exhibit the error

Actions #2

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.6 to 6.1.7
Actions #3

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.7 to 6.1.8
Actions #4

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.8 to 6.1.9
Actions #5

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.9 to 6.1.10
Actions #6

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.10 to 6.1.11
Actions #7

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.11 to 6.1.12
Actions #8

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.12 to 6.1.13
Actions #9

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.13 to 6.1.14
Actions #10

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #11

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #12

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #13

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #14

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #15

Updated by Alexis Mousset over 2 years ago

  • Status changed from New to Rejected

6.0 is not maintained anymore.

Actions

Also available in: Atom PDF