Project

General

Profile

Actions

Bug #18539

closed

Column with node property display badly quoted values

Added by François ARMAND over 3 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
3
Category:
Web - Nodes & inventories
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Name check:
To do
Fix check:
Checked
Regression:

Description

Diplay quotation is inconsitant with other parts of rudder:

GenericProperty#serializeToHocon need to be used


Files

clipboard-202011092146-qjoln.png (3.33 KB) clipboard-202011092146-qjoln.png François ARMAND, 2020-11-09 21:46
clipboard-202011171045-gnerm.png (5.37 KB) clipboard-202011171045-gnerm.png François ARMAND, 2020-11-17 10:45
clipboard-202011191756-l6cbp.png (41.6 KB) clipboard-202011191756-l6cbp.png François ARMAND, 2020-11-19 17:56

Related issues 3 (0 open3 closed)

Related to Rudder - User story #7967: Make fields of node list customizableReleasedFrançois ARMANDActions
Related to Rudder - Bug #18580: String node properties display quotesReleasedVincent MEMBRÉActions
Related to Rudder - Bug #18681: Inherited properties always displayed in the column, even if checkbox uncheckedReleasedFrançois ARMANDActions
Actions #1

Updated by François ARMAND over 3 years ago

Actions #2

Updated by François ARMAND over 3 years ago

  • Subject changed from Colomn with node property display badly quoted values to Column with node property display badly quoted values
Actions #3

Updated by François ARMAND over 3 years ago

  • Assignee set to Vincent MEMBRÉ
Actions #4

Updated by François ARMAND over 3 years ago

It also sometimes display:

Not sure why - it worked when I added the column first time.

Actions #5

Updated by François ARMAND over 3 years ago

  • Related to Bug #18580: String node properties display quotes added
Actions #6

Updated by François ARMAND over 3 years ago

It seems to be a duplicate of #18580

Actions #7

Updated by François ARMAND over 3 years ago

  • Status changed from New to Resolved
  • Fix check changed from To do to Checked

Resolved by #18580

Actions #8

Updated by Nicolas CHARLES over 3 years ago

  • Status changed from Resolved to New
  • Fix check changed from Checked to To do

This is not fixed
It shows in the node list

    "\" \\\"cjk\\\" khkh\"" 

yet the value is

" \"cjk\" khkh" 

Actions #9

Updated by François ARMAND over 3 years ago

I can't reproduce it with last version. Can you please:

- tell me on what distro?
- give me the build time stamp of rudder (displayed in webapp logs, near the start after a boot) ?

Actions #10

Updated by François ARMAND over 3 years ago

  • Priority changed from N/A to 3
Actions #11

Updated by Nicolas CHARLES over 3 years ago

  • Fix check changed from To do to Checked

it failed on Starting Rudder 6.2.0~beta2-SNAPSHOT web application [build timestamp: 2020-11-18T20:50:47Z], but worked with tonight's build

Actions #12

Updated by François ARMAND over 3 years ago

  • Related to Bug #18681: Inherited properties always displayed in the column, even if checkbox unchecked added
Actions #13

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.2.0~rc1 to 6.2.0
Actions #14

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.2.0 to 6.2.1
Actions #15

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.2.1 to 6.2.2
Actions #16

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.2.2 to 6.2.3
Actions #17

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.2.3 to 6.2.4
Actions #18

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.2.4 to 6.2.5
Actions #19

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.2.5 to 6.2.6
Actions #20

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.2.6 to 6.2.7
Actions #21

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.2.7 to 6.2.8
Actions #22

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.2.8 to 6.2.9
Actions #23

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.2.9 to 6.2.10
Actions #24

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.2.10 to 6.2.11
Actions #25

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.2.11 to 6.2.12
Actions #26

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.2.12 to 6.2.13
Actions #27

Updated by Alexis Mousset about 2 years ago

  • Status changed from New to Resolved
Actions

Also available in: Atom PDF