Project

General

Profile

Actions

Bug #18541

closed

Trigger agent run lead to JS error

Added by François ARMAND over 3 years ago. Updated about 1 year ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Web - Compliance & node report
Severity:
Minor - inconvenience | misleading | easy workaround
UX impact:
I dislike using that feature
User visibility:
Operational - other Techniques | Rudder settings | Plugins
Effort required:
Priority:
67
Name check:
To do
Fix check:
To do
Regression:
Yes

Description

I got the following error in js console when clicking on remote run for a node:

XML Parsing Error: syntax error
Location: https://192.168.29.2/rudder/secure/api/nodes/81895664-a2bf-4550-86b0-f9ad4ec9abc0/applyPolicy

If I click on the error message, firefox show the source page that looks like the corresponding URL was GET in place of POST (but I don't see that in logs)

Node property don't show afterward (at least in 7.2)


Files

clipboard-202011092206-kjwjv.png (11.6 KB) clipboard-202011092206-kjwjv.png François ARMAND, 2020-11-09 22:06
clipboard-202011092213-blbro.png (69.6 KB) clipboard-202011092213-blbro.png François ARMAND, 2020-11-09 22:13
clipboard-202011092214-eto6n.png (14.2 KB) clipboard-202011092214-eto6n.png François ARMAND, 2020-11-09 22:14

Related issues 2 (2 open0 closed)

Related to Rudder - Bug #18429: Recurrent console error: Uncaught SyntaxError: expected expression, got '<'NewRaphael GAUTHIERActions
Is duplicate of Rudder - Bug #17574: Trigger remote run leads to JS error in console and prevent displaying node properties NewRaphael GAUTHIERActions
Actions #1

Updated by François ARMAND over 3 years ago

  • Related to Bug #18429: Recurrent console error: Uncaught SyntaxError: expected expression, got '<' added
Actions #2

Updated by Nicolas CHARLES over 3 years ago

  • Target version changed from 6.2.0~rc1 to 6.1.7

Happens on 6.1 & 6.0, see https://issues.rudder.io/issues/17574

Actions #3

Updated by Nicolas CHARLES over 3 years ago

  • Related to Bug #17574: Trigger remote run leads to JS error in console and prevent displaying node properties added
Actions #4

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.7 to 6.1.8
Actions #5

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.8 to 6.1.9
Actions #6

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.1.9 to 6.1.10
Actions #7

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.10 to 6.1.11
Actions #8

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.11 to 6.1.12
Actions #9

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.12 to 6.1.13
Actions #10

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.13 to 6.1.14
Actions #11

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #12

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #13

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #14

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #15

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #16

Updated by François ARMAND over 2 years ago

Still the case in 7.0 (just run a remote run, even for root server)

Actions #17

Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 6.1.19 to 6.1.20
Actions #18

Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 6.1.20 to 6.1.21
Actions #19

Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 6.1.21 to old 6.1 issues to relocate
Actions #20

Updated by Nicolas CHARLES over 1 year ago

  • Regression set to No

still in 7.2
It prevents also the display of node properties afterward

Actions #21

Updated by Nicolas CHARLES over 1 year ago

  • Description updated (diff)
Actions #22

Updated by François ARMAND over 1 year ago

  • Target version changed from old 6.1 issues to relocate to 6.2.20
  • Severity set to Minor - inconvenience | misleading | easy workaround
  • UX impact set to I dislike using that feature
  • User visibility set to Operational - other Techniques | Rudder settings | Plugins
  • Priority changed from 0 to 67
  • Regression changed from No to Yes

The UX is now more impacted since it breaks other part of the UI

Actions #23

Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 6.2.20 to old 6.2 issues to relocate
Actions #24

Updated by François ARMAND about 1 year ago

  • Related to deleted (Bug #17574: Trigger remote run leads to JS error in console and prevent displaying node properties )
Actions #25

Updated by François ARMAND about 1 year ago

  • Is duplicate of Bug #17574: Trigger remote run leads to JS error in console and prevent displaying node properties added
Actions #26

Updated by François ARMAND about 1 year ago

  • Status changed from New to Rejected

Duplicates of #17574

Actions

Also available in: Atom PDF