Project

General

Profile

Actions

Bug #18810

closed

Inventories processed after several hours

Added by François ARMAND over 3 years ago. Updated about 2 years ago.

Status:
Rejected
Priority:
N/A
Category:
Web - Nodes & inventories
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Name check:
To do
Fix check:
To do
Regression:

Description

On a rudder 6.2.0, inventories are not coming in "pending node" before a lots of time.

In the log, we can see:

[2021-01-06 16:49:44+0100] INFO  inventory-processing - Watch new inventory file 'xxx-99c6333c-6df1-4da0-84fc-f5af75cc2367.ocs' with signature available: process.
[2021-01-06 16:49:45+0100] INFO  inventory-processing - Watch new inventory file 'xxx-99c6333c-6df1-4da0-84fc-f5af75cc2367.ocs' with signature available: process.

And the corresponding inventories remain forever in /var/rudder/inventories/incoming

If we touch only one file, it works as expected:

[2021-01-06 16:37:04+0100] INFO  inventory-processing - Watch new inventory file 'xxx-99c6333c-6df1-4da0-84fc-f5af75cc2367.ocs' with signature available: process.
[2021-01-06 16:40:49+0100] INFO  inventory-processing - Report 'xxx-99c6333c-6df1-4da0-84fc-f5af75cc2367.ocs' for node 'v-mysql02' [99c6333c-6df1-4da0-84fc-f5af75cc2367] (signature:certified) processed in 3 minutes, 40 seconds and 399 milliseconds ms

And if we wait a couple second before before adding each file, it starts as expected but never ends:

[2021-01-06 16:57:07+0100] TRACE inventory-processing - Processing new file: /var/rudder/inventories/incoming/xxx-99c6333c-6df1-4da0-84fc-f5af75cc2367.ocs
[2021-01-06 16:57:07+0100] DEBUG inventory-processing - Watch new inventory file 'xxx-99c6333c-6df1-4da0-84fc-f5af75cc2367.ocs' without signature available: wait for it 10s before processing.
[2021-01-06 16:57:15+0100] DEBUG inventory-processing - Not starting process of 'xxx-99c6333c-6df1-4da0-84fc-f5af75cc2367.ocs.sign': already processing.
Actions #1

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.2.1 to 6.2.2
Actions #2

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.2.2 to 6.2.3
Actions #3

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.2.3 to 6.2.4
Actions #4

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.2.4 to 6.2.5
Actions #5

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.2.5 to 6.2.6
Actions #6

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.2.6 to 6.2.7
Actions #7

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.2.7 to 6.2.8
Actions #8

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.2.8 to 6.2.9
Actions #9

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.2.9 to 6.2.10
Actions #10

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.2.10 to 6.2.11
Actions #11

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.2.11 to 6.2.12
Actions #12

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.2.12 to 6.2.13
Actions #13

Updated by François ARMAND about 2 years ago

  • Status changed from New to Rejected

This ticket can not be reproduced. I'm closing it, since I don't see how to correct it without a reproducer.

Actions

Also available in: Atom PDF