Project

General

Profile

Actions

Bug #18821

closed

Permissions in inventories folder

Added by Jeremy CHAMPEL over 3 years ago. Updated about 1 month ago.

Status:
Resolved
Priority:
N/A
Assignee:
-
Category:
Web - Nodes & inventories
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Name check:
To do
Fix check:
To do
Regression:
No

Description

On deb 10 rudder server 6.2.0, always upgraded through apt on latest repo,

Files seem to have strange permissions in inventories folders:

 root@rudder:/var/rudder/inventories# l
total 82M
drwxr-x--x   8 root     root   4,0K janv. 10 16:45 .
drwxr-xr-x  20 root     root   4,0K août   6 15:28 ..
drwxrwx---   2 www-data rudder  48K janv. 11 14:35 accepted-nodes-updates
drwxrwx---   2 root     root    81M janv. 11 14:33 debug
drwxrwx---   2 www-data rudder  32K janv. 11 14:11 failed
drwxr-xr-x 465 root     root    36K janv.  8 17:32 historical
drwxrwx---   2 www-data rudder 4,0K janv. 11 14:31 incoming
drwxr-xr-x   2 root     root   116K janv. 11 14:33 received
root@rudder:/var/rudder/inventories# l incoming/
total 4,0M
drwxrwx--- 2 www-data rudder   4,0K janv. 11 14:37 .
drwxr-x--x 8 root     root     4,0K janv. 10 16:45 ..
-rw-rw---- 1 root     root     330K janv. 11 12:35 ftp-cc65b80b-8dce-41a2-8e3a-fe81eb001496.ocs
-rw-r--r-- 1 www-data www-data 1,2K janv. 11 12:35 ftp-cc65b80b-8dce-41a2-8e3a-fe81eb001496.ocs.sign
-rw-rw---- 1 root     root     457K janv. 11 14:16 wazo-614bf116-3a69-4e39-9e90-0439a691db5e.ocs
-rw-r--r-- 1 www-data www-data 1,2K janv. 11 14:16 wazo-614bf116-3a69-4e39-9e90-0439a691db5e.ocs.sign
-rw-rw---- 1 root     root     397K janv. 11 14:16 moulin03p-video-d2ec1fdb-973a-44cf-aa05-9d9d2bc9626e.ocs
-rw-r--r-- 1 www-data www-data 1,2K janv. 11 14:16 moulin03p-video-d2ec1fdb-973a-44cf-aa05-9d9d2bc9626e.ocs.sign
Actions #1

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.2.1 to 6.2.2
Actions #2

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 6.2.2 to 6.2.3
Actions #3

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.2.3 to 6.2.4
Actions #4

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.2.4 to 6.2.5
Actions #5

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.2.5 to 6.2.6
Actions #6

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.2.6 to 6.2.7
Actions #7

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.2.7 to 6.2.8
Actions #8

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.2.8 to 6.2.9
Actions #9

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.2.9 to 6.2.10
Actions #10

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.2.10 to 6.2.11
Actions #11

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.2.11 to 6.2.12
Actions #12

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.2.12 to 6.2.13
Actions #13

Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 6.2.13 to 6.2.14
Actions #14

Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 6.2.14 to 6.2.15
Actions #15

Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 6.2.15 to 6.2.16
Actions #16

Updated by Alexis Mousset almost 2 years ago

  • Target version changed from 6.2.16 to 6.2.17
Actions #17

Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 6.2.17 to 997
Actions #18

Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 997 to 6.2.18
Actions #19

Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 6.2.18 to 6.2.19
Actions #20

Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 6.2.19 to 6.2.20
Actions #21

Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 6.2.20 to old 6.2 issues to relocate
Actions #22

Updated by Alexis Mousset 10 months ago

  • Target version changed from old 6.2 issues to relocate to 7.2.11
  • Regression set to No

still happens, no idea why. Probably the webapp's fault, relayd doe not do anything different for these files.

Actions #23

Updated by Vincent MEMBRÉ 9 months ago

  • Target version changed from 7.2.11 to 1046
Actions #24

Updated by Alexis Mousset 8 months ago

  • Target version changed from 1046 to 7.3.8
Actions #25

Updated by Vincent MEMBRÉ 7 months ago

  • Target version changed from 7.3.8 to 7.3.9
Actions #26

Updated by Vincent MEMBRÉ 7 months ago

  • Target version changed from 7.3.9 to 7.3.10
Actions #27

Updated by Vincent MEMBRÉ 6 months ago

  • Target version changed from 7.3.10 to 7.3.11
Actions #28

Updated by Vincent MEMBRÉ 4 months ago

  • Target version changed from 7.3.11 to 7.3.12
Actions #29

Updated by Vincent MEMBRÉ 3 months ago

  • Target version changed from 7.3.12 to 7.3.13
Actions #30

Updated by Vincent MEMBRÉ 3 months ago

  • Target version changed from 7.3.13 to 7.3.14
Actions #31

Updated by Vincent MEMBRÉ about 1 month ago

  • Target version changed from 7.3.14 to 7.3.15
Actions #32

Updated by François ARMAND about 1 month ago

  • Status changed from New to Resolved

This seems to be corrected in Rudder 8.1.

Actions

Also available in: Atom PDF